I have 2 classes: DistanceMatrix and VehicleTypeDistanceMatrix
DistanceMatrix takes an orign and destination, its job is to find on travel time and distance
VehicleTypeDistanceMatrix takes an origin and a vehicle type, its job is to find the average wait time.
I m not happy with the naming. It does not convey the meaning well.