Thavo
1 week ago
147
6
Laravel

Guzzlehttp Error While Upgrading Laravel to 8 from 7

Posted 1 week ago by Thavo

I'am following this guide: https://laravel.com/docs/8.x/upgrade#upgrade-8.0

However after I run composer update it throws me an error

our requirements could not be resolved to an installable set of packages.
    - Conclusion: don't install guzzlehttp/guzzle 7.0.1
    - Conclusion: don't install guzzlehttp/guzzle 7.1.x-dev
    - php-http/guzzle6-adapter v2.0.1 requires guzzlehttp/guzzle ^6.0 -> satisfiable by guzzlehttp/guzzle[6.5.x-dev].
    - php-http/guzzle6-adapter 2.x-dev requires guzzlehttp/guzzle ^6.0 -> satisfiable by guzzlehttp/guzzle[6.5.x-dev].
    - php-http/guzzle6-adapter v2.0.0 requires guzzlehttp/guzzle ^6.0 -> satisfiable by guzzlehttp/guzzle[6.5.x-dev].
    - php-http/guzzle6-adapter v2.0.1 requires guzzlehttp/guzzle ^6.0 -> satisfiable by guzzlehttp/guzzle[6.5.x-dev].
    - Can only install one of: guzzlehttp/guzzle[7.0.x-dev, 6.5.x-dev].
    - Can only install one of: guzzlehttp/guzzle[7.0.x-dev, 6.5.x-dev].
    - Installation request for guzzlehttp/guzzle ^7.0.1 -> satisfiable by guzzlehttp/guzzle[7.0.1, 7.0.x-dev, 7.1.x-dev].
    - Installation request for php-http/guzzle6-adapter ^2.0 -> satisfiable by php-http/guzzle6-adapter[2.x-dev, v2.0.0, v2.0.1].

My composer:

"require": {
        "php": "^7.3",
        "fideloper/proxy": "^4.2",
        "fruitcake/laravel-cors": "^1.0",
        "guzzlehttp/guzzle": "^7.0.1",
        "jailtonsc/validador-cpf-laravel": "^5.0",
        "laravel/framework": "^8.0",
        "laravel/legacy-factories": "^1.0",
        "laravel/telescope": "^3.5",
        "laravel/tinker": "^2.0",
        "laravel/ui": "^3.0",
        "league/flysystem-aws-s3-v3": "^1.0",
        "php-http/guzzle6-adapter": "^2.0",
        "rap2hpoutre/laravel-log-viewer": "^1.6",
        "sentry/sentry-laravel": "1.8.0",
        "spatie/image-optimizer": "^1.2",
        "spatie/laravel-backup": "^6.11",
        "spatie/laravel-permission": "^3.13",
        "yajra/laravel-datatables-oracle": "~9.0"
    },
    "require-dev": {
        "facade/ignition": "^2.3.6",
        "fzaninotto/faker": "^1.9.1",
        "mockery/mockery": "^1.3.1",
        "nunomaduro/collision": "^5",
        "phpunit/phpunit": "^9"
    },

How to fix that?

Please sign in or create an account to participate in this conversation.