Thavo

Thavo

Member Since 5 Years Ago

Experience Points
4,750
Total
Experience

250 experience to go until the next level!

In case you were wondering, you earn Laracasts experience when you:

  • Complete a lesson — 100pts
  • Create a forum thread — 50pts
  • Reply to a thread — 10pts
  • Leave a reply that is liked — 50pts
  • Receive a "Best Reply" award — 500pts
Lessons Completed
50
Lessons
Completed
Best Reply Awards
0
Best Reply
Awards
  • start your engines Created with Sketch.

    Start Your Engines

    Earned once you have completed your first Laracasts lesson.

  • first-thousand Created with Sketch.

    First Thousand

    Earned once you have earned your first 1000 experience points.

  • 1-year Created with Sketch.

    One Year Member

    Earned when you have been with Laracasts for 1 year.

  • 2-years Created with Sketch.

    Two Year Member

    Earned when you have been with Laracasts for 2 years.

  • 3-years Created with Sketch.

    Three Year Member

    Earned when you have been with Laracasts for 3 years.

  • 4-years Created with Sketch.

    Four Year Member

    Earned when you have been with Laracasts for 4 years.

  • 5-years Created with Sketch.

    Five Year Member

    Earned when you have been with Laracasts for 5 years.

  • school-in-session Created with Sketch.

    School In Session

    Earned when at least one Laracasts series has been fully completed.

  • welcome-newcomer Created with Sketch.

    Welcome To The Community

    Earned after your first post on the Laracasts forum.

  • full-time-student Created with Sketch.

    Full Time Learner

    Earned once 100 Laracasts lessons have been completed.

  • pay-it-forward Created with Sketch.

    Pay It Forward

    Earned once you receive your first "Best Reply" award on the Laracasts forum.

  • subscriber Created with Sketch.

    Subscriber

    Earned if you are a paying Laracasts subscriber.

  • lifer Created with Sketch.

    Lifer

    Earned if you have a lifetime subscription to Laracasts.

  • evangelist Created with Sketch.

    Laracasts Evangelist

    Earned if you share a link to Laracasts on social media. Please email [email protected] with your username and post URL to be awarded this badge.

  • chatty-cathy Created with Sketch.

    Chatty Cathy

    Earned once you have achieved 500 forum replies.

  • lara-veteran Created with Sketch.

    Laracasts Veteran

    Earned once your experience points passes 100,000.

  • 10k-strong Created with Sketch.

    Ten Thousand Strong

    Earned once your experience points hits 10,000.

  • lara-master Created with Sketch.

    Laracasts Master

    Earned once 1000 Laracasts lessons have been completed.

  • laracasts-tutor Created with Sketch.

    Laracasts Tutor

    Earned once your "Best Reply" award count is 100 or more.

  • laracasts-sensei Created with Sketch.

    Laracasts Sensei

    Earned once your experience points passes 1 million.

  • top-50 Created with Sketch.

    Top 50

    Earned once your experience points ranks in the top 50 of all Laracasts users.

Level 1
4,750 XP
Sep
16
2 days ago
Activity icon

Replied to Guzzlehttp Error While Upgrading Laravel To 8 From 7

Thanks for the attention I fixed the issue

Sep
15
3 days ago
Activity icon

Replied to Guzzlehttp Error While Upgrading Laravel To 8 From 7

Hello Ishra

I tried to install that sentry version however I got that error:


  Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package laravel/framework (locked at v7.28.1, required as ^8.0) is satisfiable by laravel/framework[v7.28.1] but these conflict with your requirements or minimum-stability.
  Problem 2
    - The requested package laravel/ui (locked at v2.4.0, required as ^3.0) is satisfiable by laravel/ui[v2.4.0] but these conflict with your requirements or minimum-stability.
  Problem 3
    - The requested package nunomaduro/collision (locked at v4.2.0, required as ^5) is satisfiable by nunomaduro/collision[v4.2.0] but these conflict with your requirements or minimum-stability.
  Problem 4
    - The requested package phpunit/phpunit (locked at 8.5.8, required as ^9) is satisfiable by phpunit/phpunit[8.5.8] but these conflict with your requirements or minimum-stability.
  Problem 5
    - Conclusion: don't install laravel/framework v8.3.0
    - Conclusion: don't install laravel/framework v8.0.4
    - Conclusion: don't install laravel/framework v8.0.3
    - Conclusion: don't install laravel/framework v8.0.2
    - Installation request for laravel/telescope (locked at v3.5.1, required as ^3.5) -> satisfiable by laravel/telescope[v3.5.1].
    - Conclusion: don't install laravel/framework v8.0.1
    - Conclusion: don't install laravel/framework v8.0.0
    - don't install illuminate/macroable v8.2.0|don't install laravel/framework 8.x-dev
    - don't install laravel/framework 8.x-dev|remove illuminate/macroable v8.2.0
    - don't install laravel/framework 8.x-dev|don't install illuminate/macroable v8.2.0
    - Installation request for laravel/framework ^8.0 -> satisfiable by laravel/framework[8.x-dev, v8.0.0, v8.0.1, v8.0.2, v8.0.3, v8.0.4, v8.1.0, v8.2.0, v8.3.0].
    - Installation request for illuminate/macroable (locked at v8.2.0) -> satisfiable by illuminate/macroable[v8.2.0], laravel/framework[v8.2.0].
Activity icon

Replied to Guzzlehttp Error While Upgrading Laravel To 8 From 7

Hello Ishra,

Thanks for the attention, I've updated composer however now I'm getting another error:

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: don't install laravel/framework v8.2.0
    - Conclusion: don't install laravel/framework v8.1.0
    - Conclusion: don't install laravel/framework v8.0.4
    - Conclusion: don't install laravel/framework v8.0.3
    - Conclusion: don't install laravel/framework v8.0.2
    - Conclusion: don't install laravel/framework v8.0.1
    - Conclusion: don't install laravel/framework v8.0.0

....
- Installation request for laravel/framework ^8.0 -> satisfiable by laravel/framework[8.x-dev, v8.0.0, v8.0.1, v8.0.2, v8.0.3, v8.0.4, v8.1.0, v8.2.0].
    - Installation request for sentry/sentry-laravel 1.8.0 -> satisfiable by sentry/sentry-laravel[1.8.0].

My Composer.json

"require": {
        "php": "^7.3",
        "fideloper/proxy": "^4.2",
        "fruitcake/laravel-cors": "^1.0",
        "guzzlehttp/guzzle": "^6.5|^7.0.1",
        "jailtonsc/validador-cpf-laravel": "^5.0",
        "laravel/framework": "^8.0",
        "laravel/legacy-factories": "^1.0",
        "laravel/telescope": "^3.5",
        "laravel/tinker": "^2.0",
        "laravel/ui": "^3.0",
        "league/flysystem-aws-s3-v3": "^1.0",
        "php-http/guzzle6-adapter": "^2.0",
        "rap2hpoutre/laravel-log-viewer": "^1.6",
        "sentry/sentry-laravel": "1.8.0",
        "spatie/image-optimizer": "^1.2",
        "spatie/laravel-backup": "^6.11",
        "spatie/laravel-permission": "^3.13",
        "yajra/laravel-datatables-oracle": "~9.0"
    },
    "require-dev": {
        "facade/ignition": "^2.3.6",
        "fzaninotto/faker": "^1.9.1",
        "mockery/mockery": "^1.3.1",
        "nunomaduro/collision": "^5",
        "phpunit/phpunit": "^9"
    },
Sep
14
4 days ago
Activity icon

Started a new Conversation Guzzlehttp Error While Upgrading Laravel To 8 From 7

I'am following this guide: https://laravel.com/docs/8.x/upgrade#upgrade-8.0

However after I run composer update it throws me an error

our requirements could not be resolved to an installable set of packages.
    - Conclusion: don't install guzzlehttp/guzzle 7.0.1
    - Conclusion: don't install guzzlehttp/guzzle 7.1.x-dev
    - php-http/guzzle6-adapter v2.0.1 requires guzzlehttp/guzzle ^6.0 -> satisfiable by guzzlehttp/guzzle[6.5.x-dev].
    - php-http/guzzle6-adapter 2.x-dev requires guzzlehttp/guzzle ^6.0 -> satisfiable by guzzlehttp/guzzle[6.5.x-dev].
    - php-http/guzzle6-adapter v2.0.0 requires guzzlehttp/guzzle ^6.0 -> satisfiable by guzzlehttp/guzzle[6.5.x-dev].
    - php-http/guzzle6-adapter v2.0.1 requires guzzlehttp/guzzle ^6.0 -> satisfiable by guzzlehttp/guzzle[6.5.x-dev].
    - Can only install one of: guzzlehttp/guzzle[7.0.x-dev, 6.5.x-dev].
    - Can only install one of: guzzlehttp/guzzle[7.0.x-dev, 6.5.x-dev].
    - Installation request for guzzlehttp/guzzle ^7.0.1 -> satisfiable by guzzlehttp/guzzle[7.0.1, 7.0.x-dev, 7.1.x-dev].
    - Installation request for php-http/guzzle6-adapter ^2.0 -> satisfiable by php-http/guzzle6-adapter[2.x-dev, v2.0.0, v2.0.1].

My composer:

"require": {
        "php": "^7.3",
        "fideloper/proxy": "^4.2",
        "fruitcake/laravel-cors": "^1.0",
        "guzzlehttp/guzzle": "^7.0.1",
        "jailtonsc/validador-cpf-laravel": "^5.0",
        "laravel/framework": "^8.0",
        "laravel/legacy-factories": "^1.0",
        "laravel/telescope": "^3.5",
        "laravel/tinker": "^2.0",
        "laravel/ui": "^3.0",
        "league/flysystem-aws-s3-v3": "^1.0",
        "php-http/guzzle6-adapter": "^2.0",
        "rap2hpoutre/laravel-log-viewer": "^1.6",
        "sentry/sentry-laravel": "1.8.0",
        "spatie/image-optimizer": "^1.2",
        "spatie/laravel-backup": "^6.11",
        "spatie/laravel-permission": "^3.13",
        "yajra/laravel-datatables-oracle": "~9.0"
    },
    "require-dev": {
        "facade/ignition": "^2.3.6",
        "fzaninotto/faker": "^1.9.1",
        "mockery/mockery": "^1.3.1",
        "nunomaduro/collision": "^5",
        "phpunit/phpunit": "^9"
    },

How to fix that?