denewey

at Connectivity

Member Since 2 Years Ago

Largo, FL

Experience Points
600
Total
Experience

4,400 experience to go until the next level!

In case you were wondering, you earn Laracasts experience when you:

  • Complete a lesson — 100pts
  • Create a forum thread — 50pts
  • Reply to a thread — 10pts
  • Leave a reply that is liked — 50pts
  • Receive a "Best Reply" award — 500pts
Lessons Completed
3
Lessons
Completed
Best Reply Awards
0
Best Reply
Awards
  • start your engines Created with Sketch.

    Start Your Engines

    Earned once you have completed your first Laracasts lesson.

  • first-thousand Created with Sketch.

    First Thousand

    Earned once you have earned your first 1000 experience points.

  • 1-year Created with Sketch.

    One Year Member

    Earned when you have been with Laracasts for 1 year.

  • 2-years Created with Sketch.

    Two Year Member

    Earned when you have been with Laracasts for 2 years.

  • 3-years Created with Sketch.

    Three Year Member

    Earned when you have been with Laracasts for 3 years.

  • 4-years Created with Sketch.

    Four Year Member

    Earned when you have been with Laracasts for 4 years.

  • 5-years Created with Sketch.

    Five Year Member

    Earned when you have been with Laracasts for 5 years.

  • school-in-session Created with Sketch.

    School In Session

    Earned when at least one Laracasts series has been fully completed.

  • welcome-newcomer Created with Sketch.

    Welcome To The Community

    Earned after your first post on the Laracasts forum.

  • full-time-student Created with Sketch.

    Full Time Learner

    Earned once 100 Laracasts lessons have been completed.

  • pay-it-forward Created with Sketch.

    Pay It Forward

    Earned once you receive your first "Best Reply" award on the Laracasts forum.

  • subscriber Created with Sketch.

    Subscriber

    Earned if you are a paying Laracasts subscriber.

  • lifer Created with Sketch.

    Lifer

    Earned if you have a lifetime subscription to Laracasts.

  • evangelist Created with Sketch.

    Laracasts Evangelist

    Earned if you share a link to Laracasts on social media. Please email [email protected] with your username and post URL to be awarded this badge.

  • chatty-cathy Created with Sketch.

    Chatty Cathy

    Earned once you have achieved 500 forum replies.

  • lara-veteran Created with Sketch.

    Laracasts Veteran

    Earned once your experience points passes 100,000.

  • 10k-strong Created with Sketch.

    Ten Thousand Strong

    Earned once your experience points hits 10,000.

  • lara-master Created with Sketch.

    Laracasts Master

    Earned once 1000 Laracasts lessons have been completed.

  • laracasts-tutor Created with Sketch.

    Laracasts Tutor

    Earned once your "Best Reply" award count is 100 or more.

  • laracasts-sensei Created with Sketch.

    Laracasts Sensei

    Earned once your experience points passes 1 million.

  • top-50 Created with Sketch.

    Top 50

    Earned once your experience points ranks in the top 50 of all Laracasts users.

  • Community Pillar

    Earned once your experience points ranks in the top 10 of all Laracasts users.

Level 1
600 XP
May
06
2 days ago
Activity icon

Replied to Datepicker Not Displaying

The console has one message: DevTools failed to load SourceMap: Could not load content for https://neutralconnect.lytyx.com/assets/app/vendor/underscore/underscore-min.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

The original site where the datepicker works has the same error in the console.

HOWEVER, the original site has a lot of other error messages in the console:

moment-with-locales.min.js?_version=1.9.3:20 Deprecation warning: value provided is not in a recognized ISO format. moment construction falls back to js Date(), which is not reliable across all browsers and versions. Non ISO date formats are discouraged and will be removed in an upcoming major release. Please refer to http://momentjs.com/guides/#/warnings/js-date/ for more info. Arguments: [0] _isAMomentObject: true, _isUTC: false, _useUTC: false, _l: undefined, _i: 5/5/2021, _f: undefined, _strict: false, _locale: [object Object] Error at Function.createFromInputFallback (https://neutralconnect.connectlytix.org/assets/app/vendor/moment/moment-with-locales.min.js?_version=1.9.3:20:668) at eb (https://neutralconnect.connectlytix.org/assets/app/vendor/moment/moment-with-locales.min.js?_version=1.9.3:132:129) at pb (https://neutralconnect.connectlytix.org/assets/app/vendor/moment/moment-with-locales.min.js?_version=1.9.3:172:413) at ob (https://neutralconnect.connectlytix.org/assets/app/vendor/moment/moment-with-locales.min.js?_version=1.9.3:172:274) at nb (https://neutralconnect.connectlytix.org/assets/app/vendor/moment/moment-with-locales.min.js?_version=1.9.3:170:503) at qb (https://neutralconnect.connectlytix.org/assets/app/vendor/moment/moment-with-locales.min.js?_version=1.9.3:177:164) at rb (https://neutralconnect.connectlytix.org/assets/app/vendor/moment/moment-with-locales.min.js?_version=1.9.3:177:198) at a (https://neutralconnect.connectlytix.org/assets/app/vendor/moment/moment-with-locales.min.js?_version=1.9.3:6:202) at y (https://neutralconnect.connectlytix.org/assets/app/vendor/bootstrap-datetimepicker/bootstrap-datetimepicker.js?_version=1.9.3:45:184) at da (https://neutralconnect.connectlytix.org/assets/app/vendor/bootstrap-datetimepicker/bootstrap-datetimepicker.js?_version=1.9.3:64:52) v @ moment-with-locales.min.js?_version=1.9.3:20

I will look into the most recent version of moment-with-locales.min.js

Activity icon

Started a new Conversation Datepicker Not Displaying

I recently updated a Laravel site from version 5.3 to 8.38.0, also updating PHP from 5.6 to 8.0.3. I did this gradiently, handling any breaking changes as I went. The upgraded site works great, looks just like the original, with one exception - the date-picker doesn't display. When I check the Elements tab in chrome dev tools, the correct code and values show up but they are not displaying on the site, even though the CSS looks correct.

The layout and CSS of the site are created by a package called Boooya, gotten from the Envato Market site (https://themeforest.net/search/boooya). The source code as gotten from the Elements tab of the dev tool looks like this:

<div id="mainControls" class="">
        <ul>
                <li>
        <label>
            <span class="fa fa-calendar"></span>
        </label>
        <input type="text" id="mainControls-dateRange" class="form-control" data-format="M/D/YYYY" data-date="5/5/2021">
    </li>

I can provide screen shots of the CSS as it appears in chrome dev tools and the portion of the page where the datapicker is NOT displaying, but this post won't let me include those .

Apr
05
1 month ago
Activity icon

Started a new Conversation Breadcrumb Name [ ] Has Already Been Registered

After upgrading to Laravel 8 from Laravel 5.3 I'm running into problems with Breadcrums. I have installed the new Diglactic Breadcrumbs package. I updated the routes/breadcrumbs.php file per the docs and have added the new config.breadcrumbs.php.

I am now getting the error "Breadcrumb name [""] has already been registered." I have checked that there are no duplicates in the routes/breadcrumbs.php file. If I comment out the config/breadcrumbs.php file, I then get the error, "array_merge(): Argument #2 must be of type array, int given".

If I remove the config/breadcrumbs.php file altogether I again get the original error "Breadcrumbs name [""] has already been registered."

It seems to me the config/breadcrumbs.php file should remain intact with the routes/breadcrumbs.php file but I have yet to figure out why I'm getting that there are duplicate breadcrumbs.

Apr
02
1 month ago
Activity icon

Replied to Target Class [translator] Does Not Exist.

I solved this by moving:

$this->loadRoutesFrom('/var/www/laravel/routes/web.php');

into the boot() method from the register() method in AppServiceProvider

Activity icon

Started a new Conversation Target Class [translator] Does Not Exist.

After upgrading to Laravel 8 I'm getting the error:

Illuminate \ Contracts \ Container \ BindingResolutionException Target class [translator] does not exist.

This is being triggered by line 11 of my web.php file:

 'prefix' => LaravelLocalization::setLocale(),

I have namespace set in my RouteServiceProvider.php:

protected $namespace = 'App\Http\Controllers';

and added the appropropriate code in the boot() method:

public function boot()
    {
        parent::boot();

        $this->configureRateLimiting();

        $this->routes(function () {
            Route::middleware('web')
                ->namespace($this->namespace)
                ->group(base_path('routes/web.php'));

            Route::prefix('api')
                ->middleware('api')
                ->namespace($this->namespace)
                ->group(base_path('routes/api.php'));
        });
    }

Illuminate\Translation\TranslationServiceProvider is included in my config/app.php file. I've done:

 composer require symfony/translation

and

composer dump-autoload

as suggested in other posts.

The error is also referencing my register method in the AppServiceProvider:

public function register()
    {
        $this->loadRoutesFrom('/var/www/laravel/routes/web.php');
    }

Any idea what I'm missing?

Apr
01
1 month ago
Activity icon

Replied to Laravel/ui Error Despite Correct Installation

I followed the Laravel 7 to Laravel 8 upgrade guide. I suppose I should take a look at the earlier upgrade guides

Activity icon

Replied to Laravel/ui Error Despite Correct Installation

I ran 'composer install' and got the same error

Mar
31
1 month ago
Activity icon

Started a new Conversation Laravel/ui Error Despite Correct Installation

I have just upgraded to PHP 8.0.1 and Lavavel 8 from PHP 5.6 and Laravel 5.3. I included in the composer.json file require section;

"laravel/ui": "^3.0"

It has been installed in the vendor file. When I issue the command:

php artisan ui vue --auth

I get the error:

Command "ui" is not defined

I've searched everywhere and every accepted solution says to do a composer update of laravel/ui, which I've also done despite already having it in my composer file. That doesn't work.

I saw a solution to install mbstring - it's already installed.

Is there some other solution?