Pixellius

Experience

130

0 Best Reply Awards

  • Member Since 2 Weeks Ago
  • 0 Lessons Completed
  • 0 Favorites

7th November, 2017

Pixellius left a reply on {{ HTML::style}} Not Working On Local Host • 2 weeks ago

@ejdelmonico it was a 5.3.31 site,

and this

<link href="{{ asset('assets/user-module/css/main.css') }}" rel="stylesheet">

dosent work either.

I am now 90% sure its not html collective but some issue with the where the url points to just to check

in my ```homestead.yaml`` i wrote this

    - map: laravel_pilot.localhost
      to: /home/vagrant/code/laravel_pilot/public
    - map: laravel_blugate.localhost
      to: /home/vagrant/code/blugate/public

and in my etc/hosts i have

192.168.10.10   laravel_pilot.localhost
192.168.10.10   laravel_blugate.localhost

Did it mess something up?

Pixellius left a reply on {{ HTML::style}} Not Working On Local Host • 2 weeks ago

@ejdelmonico what puzzles me the most is that the production model works with exactly the same code!

Pixellius left a reply on {{ HTML::style}} Not Working On Local Host • 2 weeks ago

@a.ankitpatel Tried that too haha I've been scouring the internet for solutions to this problem.

I think im getting close tho if enter my site through the url and check the source i get the href to my css looks like this

https://laravel_pilot.localhost/public/assets/user-module/css/main.css

but if i enter through the ip address it looks like this

https://192.168.10.10/public/assets/user-module/css/main.css

which basically tells me the location that laravel appends to the url means nothing

Pixellius left a reply on {{ HTML::style}} Not Working On Local Host • 2 weeks ago

Hey ejdelmonico thanks for the responses really appreciate it. Could you elaborate on the macros? Are you referring to the html::macro() function in laravel? If so i don't have any either haha

I could just change everything to normal style tags with absolute links but there are a ton of these html::style/html::script/URL::asset things in this source code.

Pixellius left a reply on {{ HTML::style}} Not Working On Local Host • 2 weeks ago

yea i tried it without public too i think its one of the 4 snippets i had above

Pixellius left a reply on {{ HTML::style}} Not Working On Local Host • 2 weeks ago

hey a.ankitpatel thanks for your reply but sadly it still didn't work after i tried reinstalling. Is it something to do with homestead?

Pixellius left a reply on Laravel Doesn't See (almost) Any View • 2 weeks ago

Do you by any chance have data referenced in the home view? if so check your database to see if the fields you referenced are there. Maybe you forgot to migrate the database or smth

Pixellius left a reply on {{ HTML::style}} Not Working On Local Host • 2 weeks ago

bump

Pixellius started a new conversation {{ HTML::style}} Not Working On Local Host • 2 weeks ago

Hi guys im new to laravel and Ive been having this issue with html::style.

So I had some source code for a website thats online and decided to try and host it locally after going through all the installations and getting Homestead to work i ran into this issue

for some reason the line below dosen't work on my local host

{{ HTML::style('public/assets/user-module/css/main.css') }}

but this does

any idea why?

Edit Your Profile
Update

Want to change your profile photo? We pull from gravatar.com.