OshJones

OshJones

Member Since 1 Year Ago

Experience Points 510
Experience Level 1

4,490 experience to go until the next level!

In case you were wondering, you earn Laracasts experience when you:

  • Complete a lesson — 100pts
  • Create a forum thread — 50pts
  • Reply to a thread — 10pts
  • Leave a reply that is liked — 50pts
  • Receive a "Best Reply" award — 500pts
Lessons Completed 0
Lessons
Completed
Best Reply Awards 0
Best Reply
Awards
  • start-engines Created with Sketch.

    Start Your Engines

    Earned once you have completed your first Laracasts lesson.

  • first-thousand Created with Sketch.

    First Thousand

    Earned once you have earned your first 1000 experience points.

  • 1-year Created with Sketch.

    One Year Member

    Earned when you have been with Laracasts for 1 year.

  • 2-years Created with Sketch.

    Two Year Member

    Earned when you have been with Laracasts for 2 years.

  • 3-years Created with Sketch.

    Three Year Member

    Earned when you have been with Laracasts for 3 years.

  • 4-years Created with Sketch.

    Four Year Member

    Earned when you have been with Laracasts for 4 years.

  • 5-years Created with Sketch.

    Five Year Member

    Earned when you have been with Laracasts for 5 years.

  • school-session Created with Sketch.

    School In Session

    Earned when at least one Laracasts series has been fully completed.

  • welcome-newcomer Created with Sketch.

    Welcome To The Community

    Earned after your first post on the Laracasts forum.

  • full-time-student Created with Sketch.

    Full Time Learner

    Earned once 100 Laracasts lessons have been completed.

  • pay-it-forward Created with Sketch.

    Pay It Forward

    Earned once you receive your first "Best Reply" award on the Laracasts forum.

  • subscriber-token Created with Sketch.

    Subscriber

    Earned if you are a paying Laracasts subscriber.

  • lifer-token Created with Sketch.

    Lifer

    Earned if you have a lifetime subscription to Laracasts.

  • lara-evanghelist Created with Sketch.

    Laracasts Evangelist

    Earned if you share a link to Laracasts on social media. Please email [email protected] with your username and post URL to be awarded this badge.

  • chatty-cathy Created with Sketch.

    Chatty Cathy

    Earned once you have achieved 500 forum replies.

  • lara-veteran Created with Sketch.

    Laracasts Veteran

    Earned once your experience points passes 100,000.

  • 10k-strong Created with Sketch.

    Ten Thousand Strong

    Earned once your experience points hits 10,000.

  • lara-master Created with Sketch.

    Laracasts Master

    Earned once 1000 Laracasts lessons have been completed.

  • laracasts-tutor Created with Sketch.

    Laracasts Tutor

    Earned once your "Best Reply" award count is 100 or more.

  • laracasts-sensei Created with Sketch.

    Laracasts Sensei

    Earned once your experience points passes 1 million.

  • top-50 Created with Sketch.

    Top 50

    Earned once your experience points ranks in the top 50 of all Laracasts users.

03 Jun
1 year ago

OshJones left a reply on File_put_contents Error On Deploy

@arctushar It was a case of running php composer update and making sure it was loading the image intervention class from the config file.

14 Mar
1 year ago

OshJones left a reply on Blog Post Cut Off

superstar.

I should have checked before hand to be honest. It was a problem with a script for a google chart graph I have in there.

Thanks for your quick response. Much appreciated

OshJones started a new conversation Blog Post Cut Off

hi all,

i have a laravel blog based website, and some pages' content is cut off before the end of the content.

I've dd(content) and all the content seems to be there in the request. But it doesn't display it on the page.

I've double checked that it's not a max-height issue etc with the CSS.

Has anyone encountered something like this before where the whole post will not show even though all the data is stored correctly in the database.

Thanks in advance for any responses.

14 Feb
1 year ago

OshJones left a reply on Route With 2 Parameters

This is what I have for the 1st step in my route so to get the example.com/category

Route::get('insurance/{$category}', '[email protected]')->where('category', '[\w\d\-\_]+')->name('pages.category-single');

And in the Controller i have this

` public function getInsuranceCategory($category){

   return view('pages.category-single');

}`

but i get a "sorry this page could not be found"

OshJones started a new conversation Route With 2 Parameters

Can anybody help with my route problem?

I'm trying to create a route to a 'blog' but have a category and a subcategory in the url before it.

I've managed to create an example.com/category/slug URL, but I would like a example.com/category/subcategory/slug

Any feedback is greatly appreciated. Thanks a lot in advance.

OshJones left a reply on Route To Restrict Direct Access By Typing URL

Route::get('/thankyou', '[email protected]')->name('thankyou');

that's my route at the moment which obviously allows for user to type in domain and get to that page.

OshJones started a new conversation Route To Restrict Direct Access By Typing URL

I have a "thank you page" that shows up as soon as an email has been sent from a contact form. I'm trying to get my head around how i'd manage to disable direct access to this page by typing in the url of the thank you page, and only be able to access it through sending a contact form?

any ideas would be greatly appreciated

thanks in advance

01 Feb
1 year ago

OshJones left a reply on Stripped Tags On Live Server

just in case someone has this problem coming up.

It's the config file for the purifier that wasn't uploaded. All fixed after uploading this.

OshJones left a reply on Stripped Tags On Live Server

I've tried the magic_quotes route and it hasn't worked,

Any suggestions would be ideal.

It works fine on local server, so my best guess is that it's a setting on the server that I've missed.

Thanks in advance for any suggestions.

10 Jan
1 year ago

OshJones left a reply on Fwrite(): SSL: Broken Pipe / Email

did you ever get a fix for this?

05 Jan
1 year ago

OshJones left a reply on Stripped Tags On Live Server

Turns out it was the magic quotes on php.ini. It just took a bit of time to take effect.

Thank you all for your input.

OshJones left a reply on Stripped Tags On Live Server

Thanks @Thyrosis. Same PHP version, exactly the same folder structure, the only thing I could think of was the magic_quotes on php.ini that was OFF local and ON on live. But I've since changed that and it's still the same.

I don't get an error coming up.

It literally just strips all tags away from whatever I put into TinyMCE, but keeps the strong and italic tags. Annoying issue that only happens on the live.

04 Jan
1 year ago

OshJones left a reply on Stripped Tags On Live Server

Already have that.

Sorry I should have said, this works fine on a local server. But not when I put it live. So not sure if it's a setting on a server that I'm missing or not

OshJones started a new conversation Stripped Tags On Live Server

Hi all,

I've built a blog based website which uses TINY MCE as a WYSIWIG. I've configured it to allow certain things that I need. This all works fine locally.

However, I've uploaded it to a live server and it won't save the tags at all.

It saves the tag but not a h2 tag etc.

Hope this makes sense

Any ideas would be greatly appreciated.

PS running PHP 7 and turned off magic quotes.

21 Dec
1 year ago

OshJones left a reply on Email Error

Thank you both for your replies. I'll just use my gmail one temporarily to get it working. And i'll contact the host to see what they say.

Thanks again. Have a good xmas :)

20 Dec
1 year ago

OshJones left a reply on Email Error

mailtrap locally.

but i'm using one of my email addresses on my domain to send. and the details are correct. Using TSOHOST. and those are their details.

would you recommend using something like mailtrap on the live version as well?

Thanks in advance

OshJones started a new conversation Email Error

I managed to get a contact form working properly with mailtrap locally. but as soon as i went to production mode and put in real details i get the error

Expected response code 250 but got code "", with message ""

MAIL_DRIVER=smtp MAIL_HOST=mail3.gridhost.co.uk MAIL_PORT=25 MAIL_USERNAME=emailaddress MAIL_PASSWORD=emailpassword MAIL_ENCRYPTION=tls

any help would be greatly appreciated

Thanks in advance

18 Dec
1 year ago

OshJones left a reply on Laravel Mix Not Compiling Css

Yeh that fixed the issue. weird problem.

Thanks for your help.

17 Dec
1 year ago

OshJones left a reply on Laravel Mix Not Compiling Css

I'm not updating my app.css. It shows in the code that i'm compiling the correct file i hope.

The app.css is updated correctly from the scss, but it just doesn't register when i run the watch command. I'm just curious why this would be.

Thanks for your feedback

15 Dec
1 year ago

OshJones started a new conversation Laravel Mix Not Compiling Css

Hi,

currently trying to set up laravel mix to compile my scss. I run a fresh install, run npm install and npm run dev.

I'm following this video https://www.youtube.com/watch?v=TeEsyhBZhUg

However, when I run npm run watch, my js\app.js is highlighted yellow but my \cssz\app.css stays green (even when I make changes)

does anyone have any info on this please?

12 Dec
1 year ago

OshJones left a reply on File_put_contents Error On Deploy

Thanks guys, turns out it was an issue with the cache due to copy pasting the files over. Bit of a headache, but all fixed now.

Thank you all for your help.

11 Dec
1 year ago

OshJones left a reply on File_put_contents Error On Deploy

@bashy I haven't defined that path anywhere that I can remember. It is a Linux server yeah, which means the slashes are the wrong way round wherever it's defined right?

Got an hour commute home now, will have a look when I'm home again.

Thanks in advance for any help

OshJones left a reply on File_put_contents Error On Deploy

the storage folder is already there. with 3 subfolders of app, framework and logs.

OshJones started a new conversation File_put_contents Error On Deploy

Hi all,

I've never had this issue before but i get this error when I try and get my site live.

Any help will be greatly appreciated.

file_put_contents(C:\xampp\htdocs\template\storage\framework/sessions/H88urfV9i5pugcdyiTgmFp02OaIhKQ7FcGFxrJIJ): failed to open stream: No such file or directory