LordRaiders

LordRaiders

Member Since 2 Years Ago

Experience Points 190
Experience Level 1

4,810 experience to go until the next level!

In case you were wondering, you earn Laracasts experience when you:

  • Complete a lesson — 100pts
  • Create a forum thread — 50pts
  • Reply to a thread — 10pts
  • Leave a reply that is liked — 50pts
  • Receive a "Best Reply" award — 500pts
Lessons Completed 1
Lessons
Completed
Best Reply Awards 0
Best Reply
Awards
  • start-engines Created with Sketch.

    Start Your Engines

    Earned once you have completed your first Laracasts lesson.

  • first-thousand Created with Sketch.

    First Thousand

    Earned once you have earned your first 1000 experience points.

  • 1-year Created with Sketch.

    One Year Member

    Earned when you have been with Laracasts for 1 year.

  • 2-years Created with Sketch.

    Two Year Member

    Earned when you have been with Laracasts for 2 years.

  • 3-years Created with Sketch.

    Three Year Member

    Earned when you have been with Laracasts for 3 years.

  • 4-years Created with Sketch.

    Four Year Member

    Earned when you have been with Laracasts for 4 years.

  • 5-years Created with Sketch.

    Five Year Member

    Earned when you have been with Laracasts for 5 years.

  • school-session Created with Sketch.

    School In Session

    Earned when at least one Laracasts series has been fully completed.

  • welcome-newcomer Created with Sketch.

    Welcome To The Community

    Earned after your first post on the Laracasts forum.

  • full-time-student Created with Sketch.

    Full Time Learner

    Earned once 100 Laracasts lessons have been completed.

  • pay-it-forward Created with Sketch.

    Pay It Forward

    Earned once you receive your first "Best Reply" award on the Laracasts forum.

  • subscriber-token Created with Sketch.

    Subscriber

    Earned if you are a paying Laracasts subscriber.

  • lifer-token Created with Sketch.

    Lifer

    Earned if you have a lifetime subscription to Laracasts.

  • lara-evanghelist Created with Sketch.

    Laracasts Evangelist

    Earned if you share a link to Laracasts on social media. Please email [email protected] with your username and post URL to be awarded this badge.

  • chatty-cathy Created with Sketch.

    Chatty Cathy

    Earned once you have achieved 500 forum replies.

  • lara-veteran Created with Sketch.

    Laracasts Veteran

    Earned once your experience points passes 100,000.

  • 10k-strong Created with Sketch.

    Ten Thousand Strong

    Earned once your experience points hits 10,000.

  • lara-master Created with Sketch.

    Laracasts Master

    Earned once 1000 Laracasts lessons have been completed.

  • laracasts-tutor Created with Sketch.

    Laracasts Tutor

    Earned once your "Best Reply" award count is 100 or more.

  • laracasts-sensei Created with Sketch.

    Laracasts Sensei

    Earned once your experience points passes 1 million.

  • top-50 Created with Sketch.

    Top 50

    Earned once your experience points ranks in the top 50 of all Laracasts users.

10 Sep
2 years ago

LordRaiders left a reply on Error 500 When Uploading Laravel Project To Server,

Hmm I downloaded those files from internet and put it on my server and it seem to work... But when I replace it for my own files I still get the error: https://github.com/teckwei1993/laravel-in-directadmin

But I've changed the permissions for the storage folder and now it seems to work. A file called "laravel.log" appeared and it says:

[2016-09-10 23:23:46] local.ERROR: exception 'Symfony\Component\Debug\Exception\FatalErrorException' with message 'Class 'Illuminate\Notifications\NotificationServiceProvider' not found' in /home/nieckki171/domains/{{domain}}/laravel/vendor/laravel/framework/src/Illuminate/Foundation/ProviderRepository.php:146 Stack trace: #0 {main}

LordRaiders left a reply on Error 500 When Uploading Laravel Project To Server,

The console in Chrome says: "Failed to load resource: the server responded with a status of 500 (Internal Server Error)"

Is it possible that I have something wrong in the .htaccess file that is in the public folder?

Options -MultiViews

RewriteEngine On

# Redirect Trailing Slashes If Not A Folder...
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)/$ /$1 [L,R=301]

# Handle Front Controller...
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^ index.php [L]

# Handle Authorization Header
RewriteCond %{HTTP:Authorization} .
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

LordRaiders left a reply on Error 500 When Uploading Laravel Project To Server,

@tisuchi I'm uploading it in DirectAdmin but I think that works the same! I'm sure that the path is right.

The error is a 500 error and the error log says nothing.

LordRaiders left a reply on Error 500 When Uploading Laravel Project To Server,

@tisuchi It still doesn't work! What I did:

In the folder {domain}/public_html I've put all the files from the public folder.

In the {domain} folder I made a new folder called: Laravel and I put all the files except the public folder here.

In the index.php I changed the url from: /..//bootstrap/autoload.php'; to: /../Laravel/bootstrap/autoload.php';

Everything should be good now right? I'm very new with Laravel so I've no experience yet. With websites in the past it was just: Drop all your files in public_html and it should be fine :P

LordRaiders started a new conversation Error 500 When Uploading Laravel Project To Server,

When I upload my Laravel project to my server I get a 500 error (internal server error). I've installed it this way:

  • Change the database connection from local to the servers database
  • Export the local database to the server
  • Copy paste the project to /public_html

On Localhost everything works fine and even a clean install of Laravel doesn't work. In DirectAdmin I can install Laravel with the "Installtron installer" but that is a new project in Laravel 5.1.11 instead of my own project made in Laravel 5.3 .

I have no error logs when I go to the server logs or in my /storage/logs folder.

Is there something I do wrong when I install my project to the server?

I hope someone knows a solution. Thanks!