KatWalsh

KatWalsh

Member Since 1 Year Ago

Experience Points 3,570
Experience Level 1

1,430 experience to go until the next level!

In case you were wondering, you earn Laracasts experience when you:

  • Complete a lesson — 100pts
  • Create a forum thread — 50pts
  • Reply to a thread — 10pts
  • Leave a reply that is liked — 50pts
  • Receive a "Best Reply" award — 500pts
Lessons Completed 35
Lessons
Completed
Best Reply Awards 0
Best Reply
Awards
  • Start Your Engines Achievement

    Start Your Engines

    Earned once you have completed your first Laracasts lesson.

  • First Thousand Achievement

    First Thousand

    Earned once you have earned your first 1000 experience points.

  • One Year Member Achievement

    One Year Member

    Earned when you have been with Laracasts for 1 year.

  • Two Year Member Achievement

    Two Year Member

    Earned when you have been with Laracasts for 2 years.

  • Three Year Member Achievement

    Three Year Member

    Earned when you have been with Laracasts for 3 years.

  • Four Year Member Achievement

    Four Year Member

    Earned when you have been with Laracasts for 4 years.

  • Five Year Member Achievement

    Five Year Member

    Earned when you have been with Laracasts for 5 years.

  • School In Session Achievement

    School In Session

    Earned when at least one Laracasts series has been fully completed.

  • Welcome To The Community Achievement

    Welcome To The Community

    Earned after your first post on the Laracasts forum.

  • Full Time Learner Achievement

    Full Time Learner

    Earned once 100 Laracasts lessons have been completed.

  • Pay It Forward Achievement

    Pay It Forward

    Earned once you receive your first "Best Reply" award on the Laracasts forum.

  • Subscriber Achievement

    Subscriber

    Earned if you are a paying Laracasts subscriber.

  • Lifer Achievement

    Lifer

    Earned if you have a lifetime subscription to Laracasts.

  • Laracasts Evangelist Achievement

    Laracasts Evangelist

    Earned if you share a link to Laracasts on social media. Please email [email protected] with your username and post URL to be awarded this badge.

  • Chatty Cathy Achievement

    Chatty Cathy

    Earned once you have achieved 500 forum replies.

  • Laracasts Veteran Achievement

    Laracasts Veteran

    Earned once your experience points passes 100,000.

  • Ten Thousand Strong Achievement

    Ten Thousand Strong

    Earned once your experience points hits 10,000.

  • Laracasts Master Achievement

    Laracasts Master

    Earned once 1000 Laracasts lessons have been completed.

  • Laracasts Tutor Achievement

    Laracasts Tutor

    Earned once your "Best Reply" award count is 100 or more.

  • Laracasts Sensei Achievement

    Laracasts Sensei

    Earned once your experience points passes 1 million.

  • Top 50 Achievement

    Top 50

    Earned once your experience points ranks in the top 50 of all Laracasts users.

11 Jun
6 days ago

KatWalsh left a reply on Facade Root Has Not Been Set

Thank you! That cleared it up!

10 Jun
1 week ago

KatWalsh left a reply on Facade Root Has Not Been Set

Thank you! I'm on alpha1 I think, so I'll give that specific version a try tonight!

09 Jun
1 week ago

KatWalsh started a new conversation Facade Root Has Not Been Set

After a computer died a few months ago, trying to get my local dev set up on a new box.

I installed Composer, VirtualBox, Vagrant, and Homestead. Those seem to be fine. If I put a test php file in a directory, I can get to it, and it runs php correctly. I also installed phpMyAdmin for Homestead and that is also fine.

At this point I tried both a completely fresh Laravel install (5.8) AND upgrading my existing project from 5.6 to 5.8, but got the same error message when trying to access the site locally.

RuntimeException: A facade root has not been set. in /home/vagrant/code/leopards/vendor/laravel/framework/src/Illuminate/Support/Facades/Facade.php on line 234

I have not added any additional plugins - just Homestead and Laravel.

I followed the instructions here (https://laravel.com/docs/5.7/upgrade) for the 5.6 to 5.7 upgrade (added the svg directory; changed or to ?? in my blade files; added cache directory;) and then here (https://laravel.com/docs/5.8/upgrade) for the 5.7 to 5.8 upgrade (added incrementing=true for some of my pivot models). Updated my composer.json file and ran composer update.

I also tried deleting my vendor directory and composer.lock file and doing a new composer install.

Considering I'm getting the same error with a fresh install (just running 'laravel new projectname') and a project that was running fine on my previous computer, I feel like it isn't my code/application itself but something I missed in setting up this new computer, a dependency or architecture or something. I'm on Ubuntu 18.04 if that relates (which is the same as my previous computer).

Any thoughts or suggestions for what else I might try or where else I can look? I've been fighting with this for days now and it is driving me crazy!

Thanks!!!