DigiProduct

DigiProduct

Member Since 10 Months Ago

Experience Points
28,290
Total
Experience

1,710 experience to go until the next level!

In case you were wondering, you earn Laracasts experience when you:

  • Complete a lesson — 100pts
  • Create a forum thread — 50pts
  • Reply to a thread — 10pts
  • Leave a reply that is liked — 50pts
  • Receive a "Best Reply" award — 500pts
Lessons Completed
266
Lessons
Completed
Best Reply Awards
1
Best Reply
Awards
  • start-engines Created with Sketch.

    Start Your Engines

    Earned once you have completed your first Laracasts lesson.

  • first-thousand Created with Sketch.

    First Thousand

    Earned once you have earned your first 1000 experience points.

  • 1-year Created with Sketch.

    One Year Member

    Earned when you have been with Laracasts for 1 year.

  • 2-years Created with Sketch.

    Two Year Member

    Earned when you have been with Laracasts for 2 years.

  • 3-years Created with Sketch.

    Three Year Member

    Earned when you have been with Laracasts for 3 years.

  • 4-years Created with Sketch.

    Four Year Member

    Earned when you have been with Laracasts for 4 years.

  • 5-years Created with Sketch.

    Five Year Member

    Earned when you have been with Laracasts for 5 years.

  • school-session Created with Sketch.

    School In Session

    Earned when at least one Laracasts series has been fully completed.

  • welcome-newcomer Created with Sketch.

    Welcome To The Community

    Earned after your first post on the Laracasts forum.

  • full-time-student Created with Sketch.

    Full Time Learner

    Earned once 100 Laracasts lessons have been completed.

  • pay-it-forward Created with Sketch.

    Pay It Forward

    Earned once you receive your first "Best Reply" award on the Laracasts forum.

  • subscriber-token Created with Sketch.

    Subscriber

    Earned if you are a paying Laracasts subscriber.

  • lifer-token Created with Sketch.

    Lifer

    Earned if you have a lifetime subscription to Laracasts.

  • lara-evanghelist Created with Sketch.

    Laracasts Evangelist

    Earned if you share a link to Laracasts on social media. Please email [email protected] with your username and post URL to be awarded this badge.

  • chatty-cathy Created with Sketch.

    Chatty Cathy

    Earned once you have achieved 500 forum replies.

  • lara-veteran Created with Sketch.

    Laracasts Veteran

    Earned once your experience points passes 100,000.

  • 10k-strong Created with Sketch.

    Ten Thousand Strong

    Earned once your experience points hits 10,000.

  • lara-master Created with Sketch.

    Laracasts Master

    Earned once 1000 Laracasts lessons have been completed.

  • laracasts-tutor Created with Sketch.

    Laracasts Tutor

    Earned once your "Best Reply" award count is 100 or more.

  • laracasts-sensei Created with Sketch.

    Laracasts Sensei

    Earned once your experience points passes 1 million.

  • top-50 Created with Sketch.

    Top 50

    Earned once your experience points ranks in the top 50 of all Laracasts users.

Level 6
28,290 XP
Jul
13
3 months ago
Activity icon

Replied to Error In Migration

@Snapey @aurawindsurfing @nakov Many, many thanks for your time guys ...

I'm going to admit defeat and just make my changes manually.

I've wasted too much time on this .. and I've wasted too much of YOUR time as well.

Your assistance, and advice, was much appreciated

Activity icon

Replied to Error In Migration

@nakov yeah, same engine.

Everything's the same.

I've even tried using a previous migration that successfully worked to add a column .. and just changed the single line from a column to my foreign key line ... so only a single line of code different between the 2 files

Activity icon

Replied to Error In Migration

Ok, so some progress now ...

I have a local MySql installed .. and if I run migrations against that they work perfectly.

But against my MySql database at Digital Ocean, the same migrations are not working.

Yet, a migration containing just a new column (on the SAME table) works fine on my DigitalOcean server.

Does that give anyone any new ideas on what I could look at next?

Activity icon

Replied to Error In Migration

@Nakov I get that info inside Sequel Pro already ... and it doesn't contain the key.

Activity icon

Replied to Error In Migration

@nakov yes, I've disconnected Sequel Pro and reconnected it.

And, I've checked that the migration exists, and is in the migration table ... and I can even see it received a new batch number in the migration table.

And, yes, I have checked that the data types of the columns in each table are the same.

Activity icon

Replied to Error In Migration

@aurawindsurfing No. I haven't tried that ... but, at this stage, I'm willing to try just about anything ... although I'd prefer to figure out the real problem for the issue so that I can move forward secure in the knowledge that it's not going to come back and bite me during a future migration.

Will that affect any data that I have in my tables? Is it safe to do that with a database already containing data?

Really, I can solve this current situation by just manually creating the key ... but that doesn't help me understand the issue and how to stop it re-occurring.

Activity icon

Replied to Error In Migration

@aurawindsurfing I'm looking at it via Sequel Pro.

On other tables where I've used the same migration, and created a foreign key, I see a new key in the INDEXES section when I view the table structure using Sequel Pro.

However. for this table, I see nothing new in the INDEXES section.

Additionally, if I look at TableInfo tab in Sequel Pro at the Create Syntax, then just below the PRIMARY KEY in the listed structure, I expect to see the new key appear ... but I don't ...

And, I have absolutely no clue what else I can check ... hence why I asked the question ...

It's so frustrating because it should just work .. but it doesn't ... so I must be missing something really obvious but I can't figure out what ...

Activity icon

Replied to Error In Migration

@snapey @aurawindsurfing I was expecting to see a change in the structure of the database ... but I see no change at all.

If I add a column, using a migration, I see the column appear.

But using what I showed there's no new key appearing.

Activity icon

Started a new Conversation Error In Migration

This has to be my own error, but I thought I had this right and I'm hoping someone can quickly advise me what I've done wrong ....

I have the following migration, and the migration has been processed but nothing has changed to the structure of the database ... so, I must have written it wrong ...

    public function up()
    {
        Schema::table('leads', function (Blueprint $table) {
            //
            $table->foreign('location_id')->references('id')->on('locations');
        });
    }

I already have a column called "location_id" in my table "leads" ... and I have a table named "locations" which contains a column named "id"

Can anyone tell me what I'm doing wrong?

Jul
11
4 months ago
Activity icon

Started a new Conversation Get Auth Id Of An API User

How can I get the Auth:id of the authorised API user?

I'm using Laravel Passport ,and so the user is authorised for the API by the Token ...

But I want to return only the data that is "owned" by that userid ...

So, how can I get that userid when they access the the API with a token?

Jun
23
4 months ago
Activity icon

Replied to Laravel Cors Issue On Deployment

I fixed this .... somehow ... not 100% sure that this was it but ....

I added the following into the api middleware because the default installation of this package had only placed it in the web middleware

Barryvdh\Cors\ServiceProvider::class,

Jun
22
4 months ago
Activity icon

Replied to Laravel Cors Issue On Deployment

Actually, I just discovered it is NOT a deployment issue ... I alos have issues on my local server .... it's actually a issue related to POST vs GET.

All my GETs are working but my POSTs are receiving CORS errors ... both locally and on the server.

My CORS.php file reads as follows:-


    /*
    |--------------------------------------------------------------------------
    | Laravel CORS
    |--------------------------------------------------------------------------
    |
    | allowedOrigins, allowedHeaders and allowedMethods can be set to array('*')
    | to accept any value.
    |
    */
   
    'supportsCredentials' => false,
    'allowedOrigins' => ['*'],
    'allowedOriginsPatterns' => [],
    'allowedHeaders' => ['*'],
    'allowedMethods' => ['*'],
    'exposedHeaders' => [],
    'maxAge' => 0,

I've also tried with explicitly allowing all the verbs as follows:-


    /*
    |--------------------------------------------------------------------------
    | Laravel CORS
    |--------------------------------------------------------------------------
    |
    | allowedOrigins, allowedHeaders and allowedMethods can be set to array('*')
    | to accept any value.
    |
    */
   
    'supportsCredentials' => false,
    'allowedOrigins' => ['*'],
    'allowedOriginsPatterns' => [],
    'allowedHeaders' => ['*'],
    'allowedMethods' => ['PUT, GET, POST, DELETE, OPTION'],
    'exposedHeaders' => [],
    'maxAge' => 0,

Neither worked for POST ... but both work for GET

Activity icon

Replied to How To Make Animated Video Editing Or Animated Video Maker Tool? 3

You might find GSAP useful for creating the animations

Activity icon

Replied to Laravel Cors Issue On Deployment

I just realised something ... and I'm not sure if it's relevant ...

I have things working without CORS problems that defined in the web route (routes/web.php)

What isn't working are the routes that are defined in the api route (routes/api.php)

Do I need to set up something different for the API routes compared to normal WEB routes?

Activity icon

Started a new Conversation Laravel Cors Issue On Deployment

I implemented the Laravel Cors package

https://github.com/barryvdh/laravel-cors

and had it working successfuly on my local machine.

Now I've deployed it to a server, I'm getting CORS rejections again ...

I don't think that there is but ... Is there something I have forgot to run on the server during the deployment?

Jun
18
4 months ago
Activity icon

Replied to Unable To Obtain LetsEncrypt SSL Cert (some Challenges Have Failed)

@alexjustesen This isn't a direct answer to your question, but you might find it helpful info anyway.

I wanted to implement a Laravel site via Digital Ocean and was having some difficulty with Laravel Forge, so did some searching here on Laracasts, and while doing that came across a thread about Forge Alternatives

https://laracasts.com/discuss/channels/servers/forge-alternatives

In that thread I found a mention of https://moss.sh and decided to try it out ... it does LetsEncrypt too ... and it's much easier than Forge

And, they have Live Chat too ... so you can get a real person to help you.

Hope that helps.

Activity icon

Replied to Laravel Passport - Store Token In Cookies

@tomspeak I followed a set of tutorial videos by Andre Madarang that included connecting to a Laravel API from a Vue front-end.

https://www.youtube.com/playlist?list=PLEhEHUEU3x5q-xB1On4CsLPts0-rZ9oos

Because it's about Vue, there's only about 3 videos in the series that deal directly with the Laravel API ... and I know it's Vue rather than React ... but the concepts will be similar ...

You might find them useful to review.

Activity icon

Replied to Forge Alternatives

@sotekno Your link to https://moss.sh/ really helped me.

I wanted to implement a Laravel site via Digital Ocean and was having some difficulty with Laravel Forge, so did some searching here on Laracasts, and while doing that came across this thread

I checked out https://moss.sh/ was inpressed by the docs and tutorials ... PLUS they have ONLINE CHAT for support ... and I chatted with a real live person ... a very knowledgeable and helpful person.

I went ahead and implemented my site using Moss and had it up and running perfectly in no time.

https://moss.sh/ is well worth considering.

May
27
5 months ago
Activity icon

Replied to Access DigitalOcean From Windows With SSH

@artcore I tried that sql extension for VisualStudioCode but couldn't get it to work using SSH Tokens ... but thanks for mentioning it because I'll problem end up using it on other projects where I can use a username/password connection rather than tokens.

Activity icon

Replied to Access DigitalOcean From Windows With SSH

@artcore I'm using Visual Studio Code ... I never thought to look in that, but, now that I look, it has a Terminal so maybe there's some options there that I can explore ... thanks.

Ha... never loooked closely enough in Laravel Forge (because I'm very new to it) ... I just found that I can edit the .env file directly in Laravel Forge ... so that's solved!

Brilliant ... thanks @artcore I found that when looking around for remoter database in Forge and probably wouldn't have notice it without your prompting ... appreciate it.

Now, I just need remote database access ...

Activity icon

Replied to Access DigitalOcean From Windows With SSH

@mvd SSH is only available on the professional paid version of SQLyog unfortunately

Activity icon

Replied to Access DigitalOcean From Windows With SSH

@mvd I already tried those Digital Ocean ones, and I get errors if I try to use a username and password as they show ... presumably because Laravel Forge has enforced the use of SSH Keys on the droplet ...

BUT .. I'll try looking at the other tutorials you mention to see if they help ... thanks for your suggestions ...

Activity icon

Started a new Conversation Access DigitalOcean From Windows With SSH

I'm a complete newbie as far as SSH goes ... never used it before in my life.

I'm just managed to install a Laravel project onto a Digital Ocean droplet using Laravel Forge.

Laravel Forge enforces the use of SSH keys for access (at least that's how I understand it)

Does anyone know of a simple step-by-step tutorial that would get me from complete beginner to being able to view and edit the .env file and view and edit the MySQL database?

Most of the stuff I'm finding when I searched is for Mac and based around username/password instead of SSH keys ....

Could anyone point me to a windows-based tutorial that could help me?

May
18
5 months ago
Activity icon

Replied to Having A Very Rough Time Learning Laravel

Would agree with the Andre Madarang courses ... I've learnt a lot from him ... he has some very useful courses.

May
14
5 months ago
Activity icon

Replied to Laracasts Search

@jeffreyway As I said in an earlier message ....

I guess that would be because ... I'm stupid!!!

You mean the input box that says "Whatcha looking for?" don't you?

And stupid me was using the Search Icon at the top right of the page near my profile picture.

DUH!!

I hope you can't see my red face ....

May
13
5 months ago
Activity icon

Replied to Laracasts Search

@ROBSTAR - @robstar Was a sarcastic reply really necessary? I had already accepted that I had made a mistake and used the wrong search box ...

Activity icon

Replied to Need Help With An Axios Problem

Except I just realised that I don't know how to do that ... do I just apply a Best Answer?

Activity icon

Replied to Need Help With An Axios Problem

@hjortur17 You're right ... I should have done that. Will do it now.