Fix for Vagrant/Homestead - El Capitan

Published 2 years ago by graham

It looks like the Beta of OS X (El Capitan) breaks Vagrant.

It's reported that this is because /usr/bin is no longer writeable and anything that was previously installed there (e.g. Vagrant) is removed.

This is the fix that worked for me:

sudo ln -s /opt/vagrant/bin/vagrant /usr/local/bin/vagrant

Hat tip to pointless ramblings: http://pointlessramblings.com/posts/El_Capitan/

olimorris

Great tip @Graham . I had a few problems with Yosemite beta (admittedly I was running XAMPP) at the time so I may give El Capitan a whirl.

Are you enjoying it so far?

graham
graham
2 years ago (39,345 XP)

@olimorris no problems with it apart from homestead failing to start because of the Vagrant issue.

The only real difference I'm seeing so far is a performance boost, especially on Safari.

mikebronner

I did not experience these issues in Beta 2 (just updating in case anyone else is reading this looking for compatibility issues).

raphael

Graham, are you sure about that command? On my El Capitan there is no /opt/ directory in root:

/opt/vagrant/bin/vagrant: No such file or directory
AlexanderWright

Bother. I'm getting the following error:

Bringing machine 'default' up with 'virtualbox' provider...
==> default: Checking if box 'laravel/homestead' is up to date...
==> default: Clearing any previously set network interfaces...
There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["hostonlyif", "create"]

Stderr: 0%...
Progress state: NS_ERROR_FAILURE
VBoxManage: error: Failed to create the host-only adapter
VBoxManage: error: VBoxNetAdpCtl: Error while adding new interface: failed to open /dev/vboxnetctl: No such file or directory
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component HostNetworkInterface, interface IHostNetworkInterface
VBoxManage: error: Context: "int handleCreate(HandlerArg*, int, int*)" at line 66 of file VBoxManageHostonly.cpp
AlexanderWright

Ahh! Reinstalled VirtualBox (5.0.4). Slow start, but now running.

Bloomanity
 sudo chown -R $(whoami):admin /usr/local
Prullenbak

I had the same problem as @AlexanderWright Reinstalled Virutalbox (5.0.4) and then got the error

The provider 'virtualbox' that was requested to back the machine
'default' is reporting that it isn't usable on this system. The
reason is shown below:

Vagrant has detected that you have a version of VirtualBox installed
that is not supported. Please install one of the supported versions
listed below to use Vagrant:

4.0, 4.1, 4.2, 4.3

Then also reinstalled vagrant, and now it seems to be working again...

mark
mark
2 years ago (12,825 XP)

After upgrading to ElCap, I had similar issues to that mentioned above: I upgraded to VirtualBox 5.0.6 then re-installed Vagrant 1.7.4 to get back up and running.

cynosure

Just wanted to confirm that Mark's steps worked for me!! Thanks.

erikverbeek

After updating to El Capitan I got the following error when trying to run Homestead. "The guest machine entered an invalid state while waiting for it to boot."

Updating VirtualBox and Vagrant worked for me too. Thanks for the tip Mark.

deevoweb

Thank you, @mark. Easy as pie!

m91
m91
2 years ago (2,705 XP)

After upgrading I get this:

default: Warning: Connection timeout. Retrying...

Fo multiple times and then nothing, Any Ideas?

livingos

Reinstall/update VirtualBox and Vagrant and everything will be well.

robjbrain

I've had the same issue after upgrading to el capitan, re-installed virtualbox and vagrant, but now vagrant up leeds to endless "default: Warning: Connection timeout. Retrying..."

Had a google but can't find any solutions from people having the same message. Anyone else encountered this?

Please sign in or create an account to participate in this conversation.