1 week ago

PHPUnit error

Posted 1 week ago by rearmustak

I was watching this series. Now after ep02 when I run phpunit i get error but when I run php artisan test it works fine but runs all the dummy tests.

PHPUnit version = 8.2.4

Framework version = 7.22.4

My error for phpunit tests/Feature/ThreadsTest.php

Uncaught TypeError: Argument 3 passed to PHPUnit\TextUI\TestRunner::doRun() must be of the type array, bool given, called in /home/undefined/.composer/vendor/phpunit/phpunit/src/TextUI/Command.php on line 201 and defined in /media/undefined/Work/Laravel/Laracast/forum/vendor/phpunit/phpunit/src/TextUI/TestRunner.php:120 Stack trace: #0 /home/undefined/.composer/vendor/phpunit/phpunit/src/TextUI/Command.php(201): PHPUnit\TextUI\TestRunner->doRun(Object(PHPUnit\Framework\TestSuite), Array, true) #1 /home/undefined/.composer/vendor/phpunit/phpunit/src/TextUI/Command.php(160): PHPUnit\TextUI\Command->run(Array, true) #2 /home/undefined/.composer/vendor/phpunit/phpunit/phpunit(61): PHPUnit\TextUI\Command::main() #3 {main} thrown in /media/undefined/Work/Laravel/Laracast/forum/vendor/phpunit/phpunit/src/TextUI/TestRunner.php on line 120

My question is

  • How can I fix the phpunit issue ?

  • When i ran php artisan test --group=feature doesn't output anything. how can i run the specific feature test ?

Please sign in or create an account to participate in this conversation.