Homestead: First Time Setup - Npm error

I have just installed Homestead with vagrant and virtualbox for the first time. My operating system is Windows. The installation worked without problems. Now I have execute...
aurawindsurfing aurawindsurfing
1

Combine external javascript into one with webpack

Hi All, When testing one of my sites with Google PageSpeed I came across such request. Make fewer HTTP requests This page has 11 external Javascr...
Shahin Shahin
2

PHP Fileinfo extension must be installed/enabled at shared hosting

"PHP Fileinfo extension must be installed/enabled to use Intervention Image " showing this error message when I upload image on my shared hosting. So, I modified...
Propolis Propolis
2

Split web application across multiple server

I want to distribute my application across multiple servers. I would like to achieve the following: Server 1: Login portal / with user database Server 2: Web...
matt_panton matt_panton
3

Err_SSL_Protocol_Error server or client issue?

Hi all, I'm having an issue with a website that I built where when it is loaded over someones's virginmedia wifi connection, an SSL error is shown no matter what bro...
shawnyv shawnyv
7

Help with nginx & serving internal app

Hi all, I'm trying to get a laravel app set up for a client on their internal network (no access from outside world). This is the first time I've had to do an...
TylerW TylerW
2

Resources for learning how to manage server resources?

I got lucky - I made an application and it turns out there are some people who actually want to use it. I never thought I would get this far. My application is based...
mostafalaravel mostafalaravel
3

How to change PHP version in homestead

After doing the vagrant up, when I check the php version : php -v PHP 7.3.2 (cli) (built: Feb 5 2019 23:16:38) ( ZTS MSVC15 (Visual C++ 2017) x86 ) Copyrigh...
dipakrataniagile dipakrataniagile
1

Database Driver For Azure SQL

Hello Friends, Right now in my project, we are using MySQL Database. Now we want to implement the Azure SQL Database. This is my current database driver menti...

Scaling Laravel - required infrasturcture for a PaaS application

I have an application that runs on Laravel and is managed by Forge laravel. My application sends sms messages campaigns, with specific promotions. each campa...
freel freel
14

ubuntu error message extension missing

Hello, I am installing package pusher/pusher-php-server and getting error. Please see below. Can someone explain what is the problem. I don't have any idea what kind of pro...
Servers
14
98
Vishaal Vishaal
4

Laravel artisan cron task not working on ubuntu 18.10

Hello I have enabling the cron feature for Laravel on Ubuntu 18.10 on Vultr VPS server. I have added the cron task to the cron jobs list using the command...
LordRaiders LordRaiders
10

Error 500 when uploading Laravel project to server,

When I upload my Laravel project to my server I get a 500 error (internal server error). I've installed it this way: Change the database connection from loca...
Servers
10
68
mostafalaravel mostafalaravel
1

SSH php version not the same as Vagrant

Hello, when I run php version from the SSH vagrant : php -v PHP 7.1.28-1+ubuntu18.04.1+deb.sury.org+3 (cli) (built: Apr 10 2019 10:50:29) ( NTS ) Cop...
kordix kordix
2

Serve many Laravel apps (virtual hosts) on one VPS WITHOUT DOMAIN

I have laravel already working on one virtual host. But can we serve many apps on one VPS WITHOUT buying the domain, using the ip? Like...
rabol rabol
0

getmxrr not working on homestead box

Hi the function getmxrr() does not work on the Homestead dev box nor does nslookup is that a VirtualBox issue or ? Thanks in advance...
berinjelablues berinjelablues
2

How to increase storage space on Homestead Vagrant?

Hello guys. First of all, I would like to thank you all for the kindness of this community that always surprises me. Currently I came across a annoying proble...
Sabonzy Sabonzy
9

Forge Provisioned DigitalOcean Nginx 404 not found

I used forge to provision a server on Digital Ocean and when i visit the IP i get 404 Not Found. i can ping the IP and also i can ssh into the server. i have even deleted t...
isaackearl isaackearl
44

I need some socket server education.

Hello! I recently starting adding support for push notifications through socket to one of my apps, and then I realized I have no idea about server requirements for s...
Servers
44
12
vandyczech vandyczech
1

Please help me with Apache2 virtual host configuration

My Laravel run on http://84.242.117.60:9000/ Apache server is Apache/2.4.25 (Raspbian) Ho...
mhouse mhouse
4

Laravel on Centos7/Apache

I'm installing a Laravel app on a Centos 7 distro. I'm using PHP 7.2 and I've successfully installed apache and my project. I was able to get the Apache splash page...
nitinsinghnaruka nitinsinghnaruka
0

How to achieve an apache Ignore [admin-panel] URL in proxy pass on the same domain

I want to ignore admin panel from going to proxy server. My current code is - ProxyPass /...
Leff7 Leff7
9

Vagrant\Homestead - setting up multiple php versions

I have installed virtual box on my machine few months ago, and I have read that it is possible to set the PHP version per project in Homestead.yaml file, here...
Servers
9
230
Punksolid Punksolid
0

Laravel Homestead not working on manjaro

I think I did everything on the documentation I installed virtualbox and vagrant as per project configuration. I enter to my project directory executed vendor/...
murilo murilo
4

I cant connect Mysql .env Production

Hello , Please . some one can help me ? I am trying to deploy a website in this server - vultr.com . Well , I had donne everthing correctly , but It is not connectin...
uccdev uccdev
1

Do I need cron to use schedulers on Homestead?

Hi, I'm running laravel through a virtual machine run by homestead at the moment. I've set schedule = true in my Homestead.yaml and I've edited my sched...
marufalom marufalom
1

Google App Engine vs Google Compute Engine

Hi, In terms of pricing, which one good for deploying? My application is in a very early stage. We have maximum 5-10 concurrent user. Most of the times we do not have any u...
MThomas MThomas
1

Valet share does not work with WiFi but does work with mobile hotspot

I'm looking for some tips in solving the following issue. When I connect my MacBook to my home's WiFi (XS4ALL -- FritzBox 5490) and run valet share on o...
elliotk elliotk
3

Laravel Forge - Nginx respond on IP

I have been using Forge for some time, with my servers behind a load balancer (Digital Ocean). DO is currently configured to do a simple check of port 80 using TCP. This de...
snotrman snotrman
0

What URI do I need for ioredis to connect to an amazon redis server?

I'm trying to set up a chat application on heroku with redis and socket.io, but I can't figure out what uri am I suppose to put on the client side. All uri's I have...
KSHIntern1 KSHIntern1
4

Laravel 5 loading wrong .env file

I use Laravel 5 and i have the following folders on my server: /var/www/laravel_dev/ /var/www/laravel_stage/ /var/www/laravel_production/ They eac...
successdav successdav
4

Unable to connect to Mysql from mysql workbench

I am using windows, I install mysql suite and it comes with sql workbench. I have spend the whole day trying to connect mysql workbench to my database. but no luck y...
Servers
4
111
gouseferoz gouseferoz
7

My server is not loading the latest files.

Hey Guys, I have a website on nginx server and today it is loading old content instead of new content. I have checked the server and the content is new there....
ftiersch ftiersch
0

Spatie Browsershot with Docker Container

Hi, for one of my projects I need to create PDFs and I'd love to try out Spatie's Browsershot package....
Kei11 Kei11
1

AllowOverride None + Multiple Laravel App in one server

Hello guys! So in my working server, I have multiple laravel applications and also I am not allowed to use any .htaccess file (AllowOverride None). So instead...
Create a New Discussion Button