Why is php artisan serve not working anymore?

Posted 4 months ago by biniyam20

I am new to laravel development and have been migrating my web app to laravel for the past two weeks but suddenly my local server has stopped responding.

localhost:8000 does not load any page, previously it loaded my app's home page. Now, it looks like it is in an infinite request loop or something as indicated by the rotating circle on the top of the tab.

I've tried the following solutions but still no luck:

php -S localhost:8000 -t public/

as referred here https://stackoverflow.com/questions/41331631/why-command-php-artisan-serve-not-working

I have also tried other ports but I cannot successfully make a request to the server on those ports either

php artisan serve --port=8888

I have also run the code below to see which ports are active and kill those ports but I still do not receive a response after restarting the server.

 ps -ef | grep php
 sudo kill some number

I think my issue is something deeper than switching the ports up because regardless of the port, I still do not get a server response. Interestingly enough, if I whip up MAMP I do get a response from that server which is on a different port.

Can anyone advice me on getting a working server up that I can continue to use for my local development? I would prefer to not switch all of my development to a MAMP server, considering it is mainstream to develop using php artisan serve.

Please sign in or create an account to participate in this conversation.

Reply to

Use Markdown with GitHub-flavored code blocks.