Valet share does not work with WiFi but does work with mobile hotspot

Posted 2 weeks ago by MThomas

I'm looking for some tips in solving the following issue.

When I connect my MacBook to my home's WiFi (XS4ALL -- FritzBox 5490) and run valet share on one of my Laravel app's and visit the generated ngrok URL I get an DNS_PROBE_FINISHED_NXDOMAIN error in Chrome. A couple of weeks ago it worked fine.

After giving my MacBook a long overdue fresh install, the issue was not solved. This got me thinking, there is only one thing that was still the same before and after the fresh install, my network connection. So I connected to my iPhone's hotspot and ran valet share again, and this no errors visiting the ngrok URL! It worked! It showed my site.

The thing is, I have no clue what so ever where to start looking, gave the router a reboot etc, but this did not help.

Hopefully you guys can give me some tips into solving this issue...

Please sign in or create an account to participate in this conversation.

Reply to

Use Markdown with GitHub-flavored code blocks.