doni49
1348
24
Servers

Homestead/Vagrant will not load

Posted 1 year ago by doni49

I've got VirtualBox/Vagrant/Homestead installed on my Windows 10 laptop. I've also got Git Bash installed.

I been following the instructions at "https://laravel.com/docs/5.6/homestead" line-by-line. Now I'm down to the Section titled "Launching the Virtual Box". When I enter "vagrant up" (without the quotes), I get the following error message.

[email protected] MINGW64 ~/Homestead ((v7.4.0)) $ vagrant up Bringing machine 'homestead-7' up with 'virtualbox' provider... ==> homestead-7: Checking if box 'laravel/homestead' is up to date... ==> homestead-7: Clearing any previously set forwarded ports... There was an error while executing VBoxManage, a CLI used by Vagrant for controlling VirtualBox. The command and stderr is shown below.

Command: ["modifyvm", "a038793e-d20d-449c-8a9e-a5afb7a8f5fd", "--natpf1", "delete", "ssh", "--natpf1", "delete", "tcp27017", "--natpf1", "delete", "tcp33060", "--natpf1", "delete", "tcp4040", "--natpf1", "delete", "tcp44300", "--natpf1", "delete", "tcp54320", "--natpf1", "delete", "tcp8000", "--natpf1", "delete", "tcp8025"]

Stderr: VBoxManage.exe: error: Code E_FAIL (0x80004005) - Unspecified error (extended info not available) VBoxManage.exe: error: Context: "LockMachine(a->session, LockType_Write)" at line 525 of file VBoxManageModifyVM.cpp

Can anyone out there help me figure out what's going on? This is my first attempt at using a virtual machine of any kind. I'm not totally green in a *nix environment if that helps -- I've got a Raspberry Pi that I tinker with occasionally.

Please sign in or create an account to participate in this conversation.