22media
453
4
Servers

Deploying as an Azure Web App

Posted 3 years ago by 22media

I'm encountering a problem trying to deploy a fresh L5.2 app on Azure as a Web App. I configured deployment via a git push but it seems that the deployment hangs at php artisan clear-compiled until a timeout occurs.

[master]$ git push azure master
Password for 'https://[redacted]@[redacted].scm.azurewebsites.net:443': 
Counting objects: 1, done.
Writing objects: 100% (1/1), 200 bytes | 0 bytes/s, done.
Total 1 (delta 0), reused 0 (delta 0)
remote: Updating branch 'master'.
remote: Updating submodules.
remote: Preparing deployment for commit id 'db7b092bbd'.
remote: Running custom deployment command...
remote: Running deployment command...
remote: Install Dependencies with Composer
remote: .
remote: Loading composer repositories with package information
remote: Installing dependencies from lock file
remote: Nothing to install or update
remote: Generating optimized autoload files
remote: ..........................................................
remote: > php artisan clear-compiled
remote: ....................................................................................................................................................................................................
remote: 
remote: 
remote:                                                                                  
remote:   [Symfony\Component\Process\Exception\ProcessTimedOutException]                 
remote:   The process "php artisan clear-compiled" exceeded the timeout of 300 seconds.  
remote: An error has occurred during web site deployment.
remote:                                                                                  
remote: 
remote: 
remote: install [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--no-plugins] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--ignore-platform-reqs] [--] [<packages>]...
remote: 
remote: 
remote: 
remote: Error - Changes committed to remote repository but deployment to website failed.
To https://[redacted]@[redacted].scm.azurewebsites.net:443/[redacted].git
   72a7f47..db7b092  master -> master

While all these is going on, the CPU on the Azure Web App host spikes to 100% and the Kudu admin is inaccessible. I believe that php artisan is running into a kind of CPU-intensive loop that prevents even the other w3wp.exe processes from running, but I am not sure.

This may be a shot in the dark as I believe not many of us deploy to Azure on Windows. But if anyone has any experience with this, help is appreciated!

Please sign in or create an account to participate in this conversation.