4 years ago

Can't connect to Homestead (ping fails)

Posted 4 years ago by _recurse

I assume this is less of a homestead and more of a vagrant issue in general, still - maybe someone will be able to help.

I have a homestead box which suddenly stopped responding. I can do "vagrant ssh" and get into it, but I can't access my projects from the host machine (e.g. in the browser).

  1. From my host machine (OSX), ping times out
  2. From within the homestead box (vagrant ssh works), ping works and gets back to itself
  3. On the homestead box, ifconfig returns for eth1
  4. On the host machine, arp -a doesn't list the box, but I'm not sure it would do that anyway
  5. I have not modified my homestead.yaml apart from adding one project
  6. It used to work normally a couple of days ago

I already tried:

  1. Re-starting the box
  2. Re-provisioning the box
  3. Destroying and re-creating the box

All of the above worked without any unusual errors, but didn't fix the problem.

Please sign in or create an account to participate in this conversation.