Valet No Longer Working, "Unable to determine linked PHP"

Posted 1 year ago by amielkedev

I went to make some edits on a Laravel site of mine today, and my local environment with Valet no longer seems to work. I don't know what changed, but any help would be greatly appreciated.

My biggest issue is that I keep getting "In Brew.php line 187: Unable to determine linked PHP." Any time I do anything in the terminal. I've reinstalled homebrew, php, composer, and a variety of other things a number of time with no success or change.

Every time I go to run "valet install" I keep getting this message, and for some reason it keeps trying to install PHP 7.1 even though I'm running 7.2 locally. Here is exactly what I get in the terminal after running "valet install":

Stopping nginx...
Installing nginx configuration...
Installing nginx directory...
Installing php71...
Error: homebrew/dupes was deprecated. This tap is now empty as all its formulae were migrated.
Error: homebrew/versions was deprecated. This tap is now empty as all its formulae were migrated.
Error: homebrew/php was deprecated. This tap is now empty as all its formulae were migrated.
[php71] is not installed, installing it now via Brew... ?
Updating PHP configuration...

In Brew.php line 187:

  Unable to determine linked PHP.


install

I'm currently on a Mac running High Sierra, the version of PHP I'm using locally is 7.2.6, and the version of Valet installed is 2.0.6. I've been trying everything I could for the last 3.5 hours with no luck. If any more information is required to help diagnose the problem, let me know. I greatly appreciate any input or help in figuring this out!

Please sign in or create an account to participate in this conversation.