6 months ago

Uncaught TypeError: Cannot read property 'call' of undefined

Posted 6 months ago by Aqeel94321

Hi! I'm facing this error on the JavaScript console and the page won't load, I'm using the laravel-mix to compile my styles and js into separate files, the problem occur when I run "npm run production" but it doesn't output any errors when I run "npm run dev" what could be the cause?

here is the error detail

app.js:64 Uncaught TypeError: Cannot read property 'call' of undefined
    at __webpack_require__ (app.js:64)
    at Object../node_modules/css-loader/index.js!./node_modules/lightgallery.js/dist/css/lightgallery.css (3.js:29)
    at __webpack_require__ (app.js:64)
    at Object../node_modules/css-loader/index.js!./node_modules/postcss-loader/src/index.js?!./node_modules/sass-loader/dist/cjs.js?!./resources/sass/style.scss (4.js:14)
    at __webpack_require__ (app.js:64)
    at Object../resources/sass/style.scss (4.js:54)
    at __webpack_require__ (app.js:64)
    at Module../resources/js/components/pages/home/Home.js (11.js:517)
    at __webpack_require__ (app.js:64)

Please sign in or create an account to participate in this conversation.