There is no existing directory at "/storage/logs" and its not buildable: Permission denied

Posted 1 year ago by twiggy99

So this is a pretty common issue and it's usually down to permissions not being set correctly, only this time... they are. Everything was running on my local machine (Elementary OS) and remote machine (Ubuntu 16.04), the entire LEMP stack is running inside of docker containers but then I started getting the above error message both locally and on the live server and I have no idea why.

On my local system everything is running and owned by my own user, I have even set the entire storage folder system to 777 recursively yet I still get the above message. The laravel.log file and the folders all definitely exist.

On the remote machine all files are owned by one user and the docker containers are run by that same user. I have set-up the file permissions as per documented on other sites (mostly 775) but still no luck.

After 777 the entire directory locally and it's still not begin able to find the file I can only conclude it's something else that's causing the error but what is it?

Please sign in or create an account to participate in this conversation.