davy_yg
11 months ago
5967
11
Laravel

The openssl extension is required for SSL/TLS

Posted 11 months ago by davy_yg

After pulling my web with git I get this error message:

   D:\xampp2\htdocs\sesa_final\sesa-e-commerce>composer install


[Composer\Exception\NoSslException]
The openssl extension is required for SSL/TLS protection but is not available. If y
ou can not enable the openssl extension, you can disable this error, at your own ri
sk, by setting the 'disable-tls' option to true.


install [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--no-custom-installers] [--no-          autoloader] [--no-scripts] [--no-progress] [--no-suggest] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--] [<packages>]...

trying to fix it I delete the vendor folder and reinstall it yet still error.

ref: https://stackoverflow.com/questions/35249620/the-openssl-extension-is-required-for-ssl-tls-protection

When I pull the files through tortoise git there is Pull Diff button - which I ignored. Should I press it next time?

Please sign in or create an account to participate in this conversation.