kgp43
2 years ago
117
5
Laravel

Parse error: syntax error, unexpected '?' in ...

Posted 2 years ago by kgp43

Hi,

I receive this error after upgrading to 5.5:

Parse error: syntax error, unexpected '?' in /home/ubuntu/workspace/vendor/laravel/framework/src/Illuminate/Foundation/helpers.php on line 233

I have read that the error is caused by not running PHP 7. I'm already running PHP 7.1:

kgp43:~/workspace (master) $ php -v
PHP 7.1.8-2+ubuntu14.04.1+deb.sury.org+4 (cli) (built: Aug  4 2017 14:30:23) ( NTS )

What can cause this error? I cloned my old github.

Parse error: syntax error, unexpected '?' in /home/ubuntu/workspace/vendor/laravel/framework/src/Illuminate/Foundation/helpers.php on line 233


#   Time    Memory  Function    Location
1   0.0017  238968  {main}( )   .../index.php:0
2   0.0018  239632  require( '/home/ubuntu/workspace/bootstrap/autoload.php' )  .../index.php:22
3   0.0019  240296  require( '/home/ubuntu/workspace/vendor/autoload.php' ) .../autoload.php:17
4   0.0024  243808  ComposerAutoloaderInitf3abce778c71633dde0db141ebca9384::getLoader( )    .../autoload.php:7
5   0.0234  1147768 composerRequiref3abce778c71633dde0db141ebca9384( )  .../autoload_real.php:56

Please sign in or create an account to participate in this conversation.