npm install questions

Posted 2 years ago by nikocraft

I run this for first time:

npm install and get this:

npm WARN engine [email protected]: wanted: {"node":">=6.0.0"} (current:         {"node":"4.4.7","npm":"2.15.8"})
npm WARN engine [email protected]: wanted: {"node":">=4.7"} (current: {"node":"4.4.7","npm":"2.15.8"})
npm WARN optional dep failed, continuing [email protected]

What can I do about these warnings? How do I upgrade to what it wants?

It's been now stuck at that and not continued forward.

My package.json

  "devDependencies": {
    "axios": "^0.15.3",
    "bootstrap-sass": "^3.3.7",
    "jquery": "^3.1.1",
    "laravel-mix": "^0.8.1",
    "lodash": "^4.17.4",
    "vue": "^2.1.10"

Please sign in or create an account to participate in this conversation.