Melodia
1 week ago

My valet installation does not pink and brew services don't run properly

Posted 1 week ago by Melodia

Am having a hard time to run laravel projects on a mac.

After installing homebrew, I ran the following commands:

brew update

brew install php

When I run brew services list, I see the following:

Name    Status  User   Plist
mariadb stopped
mysql   started sidney /Users/sidney/Library/LaunchAgents/homebrew.mxcl.mysql.plist
php     error   root   /Library/LaunchDaemons/homebrew.mxcl.php.plist

composer global require laravel/valet

valet install

When I try to ping: ping test, it takes a few seconds, and then I see this message:

ping: cannot resolve foobar.test: Unknown host

Troubleshooting further, I ran the following commands and saw the respective results:

Sydney-de-Sousas-Mac:~ sidney$ brew doctor
Please note that these warnings are just used to help the Homebrew maintainers
with debugging if you file an issue. If everything you use Homebrew for is
working fine: please don't worry or file an issue; just ignore this. Thanks!

Warning: Unbrewed header files were found in /usr/local/include.
If you didn't put them there on purpose they could cause problems when
building Homebrew formulae, and may need to be deleted.

Warning: You have unlinked kegs in your Cellar.
Leaving kegs unlinked can lead to build-trouble and cause brews that depend on
those kegs to fail to run properly once built. Run `brew link` on these:
  mariadb
  mysql
Sydney-de-Sousas-Mac:~ sidney$ brew link mariadb
Linking /usr/local/Cellar/mariadb/10.4.6_1... 197 symlinks created
Sydney-de-Sousas-Mac:~ sidney$ brew services list
Name    Status  User   Plist
mariadb stopped
mysql   started sidney /Users/sidney/Library/LaunchAgents/homebrew.mxcl.mysql.plist
php     error   root   /Library/LaunchDaemons/homebrew.mxcl.php.plist
Sydney-de-Sousas-Mac:~ sidney$

How do I successfully install valet and run laravel projects using it?

My system version is 10.13.6 - High Sierra

Please sign in or create an account to participate in this conversation.