"laravel/cashier":"~7.0" not compatible with "stripe/stripe-php": "^6.1"

Posted 1 year ago by eddieace

I get an error when I'm trying to run

composer require "laravel/cashier":"~7.0"

The error

  Problem 1
    - laravel/cashier v7.0.9 requires stripe/stripe-php ~4.0 -> satisfiable by stripe/stripe-php[v4.0.0, v4.0.1, v4.1.0, v4.1.1, v4.10.0, v4.11.0, v4.12.0, v4.13.0, v4.2.0, v4.3.0, v4.4.0, v4.4.1, v4.4.2, v4.5.0, v4.5.1, v4.6.0, v4.7.0, v4.8.0, v4.8.1, v4.9.0, v4.9.1] but these conflict with your requirements or minimum-stability.

Maybe it should be updated so it can use the latest version of stripe-php sdk?

Anyone solved it or have a fix for it?

Please sign in or create an account to participate in this conversation.

Reply to

Use Markdown with GitHub-flavored code blocks.