laravel-oci8

Posted 6 months ago by marcellopato

I´m trying to install yajra/laravel-oci8 on Laravel 5.7.* but always got this:

composer require yajra/laravel-oci8
Using version ^5.7 for yajra/laravel-oci8
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - yajra/laravel-oci8 v5.7.3 requires ext-oci8 >=2.0.0 -> the requested PHP extension oci8 is missing from your system.
    - yajra/laravel-oci8 v5.7.2 requires ext-oci8 >=2.0.0 -> the requested PHP extension oci8 is missing from your system.
    - yajra/laravel-oci8 v5.7.1 requires ext-oci8 >=2.0.0 -> the requested PHP extension oci8 is missing from your system.
    - yajra/laravel-oci8 v5.7.0 requires ext-oci8 >=2.0.0 -> the requested PHP extension oci8 is missing from your system.
    - yajra/laravel-oci8 5.7.x-dev requires ext-oci8 >=2.0.0 -> the requested PHP extension oci8 is missing from your system.
    - yajra/laravel-oci8 5.7.x-dev requires ext-oci8 >=2.0.0 -> the requested PHP extension oci8 is missing from your system.
    - Installation request for yajra/laravel-oci8 ^5.7 -> satisfiable by yajra/laravel-oci8[5.7.x-dev, v5.7.0, v5.7.1, v5.7.2, v5.7.3].


Installation failed, reverting ./composer.json to its original content.

So I tried to install the ext-oci8 extension searching a way all the Google way, but with no success.

So how to connect to Laravel to a database Laravel 5.7, PHP 7.1?

Thanks!

Please sign in or create an account to participate in this conversation.