hal9k
1 year ago

Laravel Horizon on Mac requires ext-pcntl

Posted 1 year ago by hal9k

Hello,

I'm having problems installing Horizon on Laravel 5.5 or 5.6 on my Mac. After composer require laravel/horizon composer won't pass trough:

# composer update
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - laravel/horizon v1.3.1 requires ext-pcntl * -> the requested PHP extension pcntl is missing from your system.
    - laravel/horizon v1.3.0 requires ext-pcntl * -> the requested PHP extension pcntl is missing from your system.
    - laravel/horizon v1.3.1 requires ext-pcntl * -> the requested PHP extension pcntl is missing from your system.
    - Installation request for laravel/horizon ^1.3 -> satisfiable by laravel/horizon[v1.3.0, v1.3.1].

The only way to go around it is to run composer update --ignore-platform-reqs ext-pcntl

I use Valet on Mac with installed PHP 7.1

PHP 7.1.16 (cli) (built: Mar 31 2018 02:59:59) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2018 Zend Technologies

How do I install that ext-pcntl on my Mac?

Is there any other solution for this?

Thanks for all the answers!

Please sign in or create an account to participate in this conversation.