Seeker1337
6 months ago
985
5
Laravel

[SOLVED]Laravel 6+ VPS pointing at the wrong directory

Posted 6 months ago by Seeker1337

Hello. I've recently uploaded my website to a VPS ( Ubuntu 18.04 with Webmin/Virtualmin/LAMP ) but I ran into a few issues:

  1. Everything is set up as it should be but I'm having an issue with the files hierarchy. Here is how it looks at the moment:

/var/www/html/my-project/public

So, the problem is there is a "index.html" inside /var/www/html that gets rendered first and since it is outside of my project's folder it won't recognize any files inside my project when trying to @include them.

I edited my /etc/apache2/sites-available/000-default.conf and the DocumentRoot value to point to my Laravel public directory (/var/www/html/my-project/public) but still this file outside of the project gets pointed at and renders first.

Basically I need to point the VPS to my project's root folder and render home.blade.php first. Any help is appreciated.

Please sign in or create an account to participate in this conversation.