amidknight
2 years ago

Laravel 5.4 fresh install - composer update results in could not be resolved set of packages

Posted 2 years ago by amidknight

Only happens after adding PHP Documentor to composer.json.

{
    "name": "laravel/laravel",
    "description": "The Laravel Framework.",
    "keywords": ["framework", "laravel"],
    "license": "MIT",
    "type": "project",
    "require": {
        "php": ">=5.6.4",
        "laravel/framework": "5.4.*",
        "laravel/tinker": "~1.0"
    },
    "require-dev": {
        "fzaninotto/faker": "~1.4",
        "mockery/mockery": "0.9.*",
        "phpunit/phpunit": "~5.7",
        "phpdocumentor/phpdocumentor": "2.9.*",
        "evert/phpdoc-md" : "~0.2.0"
    },
    "autoload": {
        "classmap": [
            "database"
        ],
        "psr-4": {
            "App\\": "app/"
        }
    },
    "autoload-dev": {
        "psr-4": {
            "Tests\\": "tests/"
        }
    },
    "scripts": {
        "post-root-package-install": [
            "php -r \"file_exists('.env') || copy('.env.example', '.env');\""
        ],
        "post-create-project-cmd": [
            "php artisan key:generate"
        ],
        "post-install-cmd": [
            "Illuminate\\Foundation\\ComposerScripts::postInstall",
            "php artisan optimize"
        ],
        "post-update-cmd": [
            "Illuminate\\Foundation\\ComposerScripts::postUpdate",
            "php artisan optimize"
        ]
    },
    "config": {
        "preferred-install": "dist",
        "sort-packages": true,
        "optimize-autoloader": true
    }
}

Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: don't install symfony/finder 3.3.x-dev
    - Conclusion: don't install symfony/finder 3.2.x-dev
    - Conclusion: remove symfony/finder v3.2.7
    - Conclusion: don't install symfony/finder v3.2.7
    - Conclusion: don't install symfony/finder v3.2.6
    - Conclusion: don't install symfony/finder v3.2.5
    - Conclusion: don't install symfony/finder v3.2.4
    - Conclusion: don't install symfony/finder v3.2.3
    - Conclusion: don't install symfony/finder v3.2.2
    - Conclusion: don't install symfony/finder v3.2.1
    - Conclusion: don't install symfony/finder v3.2.0
    - Conclusion: don't install laravel/framework 5.4.x-dev
    - Conclusion: don't install symfony/finder v3.2.0-RC2
    - Installation request for phpdocumentor/phpdocumentor 2.9.* -> satisfiable by phpdocumentor/phpdocumentor[v2.9.0].
    - Conclusion: don't install symfony/finder v3.2.0-RC1
    - laravel/framework v5.4.21 requires symfony/finder ~3.2 -> satisfiable by symfony/finder[v3.2.7, 3.2.x-dev, 3.3.x-dev, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6].
    - laravel/framework v5.4.0 requires symfony/finder ~3.2 -> satisfiable by symfony/finder[v3.2.7, 3.2.x-dev, 3.3.x-dev, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6].
    - laravel/framework v5.4.1 requires symfony/finder ~3.2 -> satisfiable by symfony/finder[v3.2.7, 3.2.x-dev, 3.3.x-dev, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6].
    - laravel/framework v5.4.10 requires symfony/finder ~3.2 -> satisfiable by symfony/finder[v3.2.7, 3.2.x-dev, 3.3.x-dev, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6].
    - laravel/framework v5.4.11 requires symfony/finder ~3.2 -> satisfiable by symfony/finder[v3.2.7, 3.2.x-dev, 3.3.x-dev, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6].
    - laravel/framework v5.4.12 requires symfony/finder ~3.2 -> satisfiable by symfony/finder[v3.2.7, 3.2.x-dev, 3.3.x-dev, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6].
    - laravel/framework v5.4.13 requires symfony/finder ~3.2 -> satisfiable by symfony/finder[v3.2.7, 3.2.x-dev, 3.3.x-dev, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6].
    - laravel/framework v5.4.14 requires symfony/finder ~3.2 -> satisfiable by symfony/finder[v3.2.7, 3.2.x-dev, 3.3.x-dev, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6].
    - laravel/framework v5.4.15 requires symfony/finder ~3.2 -> satisfiable by symfony/finder[v3.2.7, 3.2.x-dev, 3.3.x-dev, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6].
    - laravel/framework v5.4.16 requires symfony/finder ~3.2 -> satisfiable by symfony/finder[v3.2.7, 3.2.x-dev, 3.3.x-dev, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6].
    - laravel/framework v5.4.17 requires symfony/finder ~3.2 -> satisfiable by symfony/finder[v3.2.7, 3.2.x-dev, 3.3.x-dev, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6].
    - laravel/framework v5.4.18 requires symfony/finder ~3.2 -> satisfiable by symfony/finder[v3.2.7, 3.2.x-dev, 3.3.x-dev, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6].
    - laravel/framework v5.4.19 requires symfony/finder ~3.2 -> satisfiable by symfony/finder[v3.2.7, 3.2.x-dev, 3.3.x-dev, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6].
    - laravel/framework v5.4.2 requires symfony/finder ~3.2 -> satisfiable by symfony/finder[v3.2.7, 3.2.x-dev, 3.3.x-dev, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6].
    - laravel/framework v5.4.20 requires symfony/finder ~3.2 -> satisfiable by symfony/finder[v3.2.7, 3.2.x-dev, 3.3.x-dev, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6].
    - laravel/framework v5.4.21 requires symfony/finder ~3.2 -> satisfiable by symfony/finder[v3.2.7, 3.2.x-dev, 3.3.x-dev, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6].
    - laravel/framework v5.4.3 requires symfony/finder ~3.2 -> satisfiable by symfony/finder[v3.2.7, 3.2.x-dev, 3.3.x-dev, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6].
    - laravel/framework v5.4.4 requires symfony/finder ~3.2 -> satisfiable by symfony/finder[v3.2.7, 3.2.x-dev, 3.3.x-dev, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6].
    - laravel/framework v5.4.5 requires symfony/finder ~3.2 -> satisfiable by symfony/finder[v3.2.7, 3.2.x-dev, 3.3.x-dev, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6].
    - laravel/framework v5.4.6 requires symfony/finder ~3.2 -> satisfiable by symfony/finder[v3.2.7, 3.2.x-dev, 3.3.x-dev, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6].
    - laravel/framework v5.4.7 requires symfony/finder ~3.2 -> satisfiable by symfony/finder[v3.2.7, 3.2.x-dev, 3.3.x-dev, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6].
    - laravel/framework v5.4.8 requires symfony/finder ~3.2 -> satisfiable by symfony/finder[v3.2.7, 3.2.x-dev, 3.3.x-dev, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6].
    - laravel/framework v5.4.9 requires symfony/finder ~3.2 -> satisfiable by symfony/finder[v3.2.7, 3.2.x-dev, 3.3.x-dev, v3.2.0, v3.2.0-BETA1, v3.2.0-RC1, v3.2.0-RC2, v3.2.1, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6].
    - Conclusion: don't install symfony/finder v3.2.0-BETA1
    - Installation request for laravel/framework 5.4.* -> satisfiable by laravel/framework[5.4.x-dev, v5.4.0, v5.4.1, v5.4.10, v5.4.11, v5.4.12, v5.4.13, v5.4.14, v5.4.15, v5.4.16, v5.4.17, v5.4.18, v5.4.19, v5.4.2, v5.4.20, v5.4.21, v5.4.3, v5.4.4, v5.4.5, v5.4.6, v5.4.7, v5.4.8, v5.4.9].

Please sign in or create an account to participate in this conversation.