Axeia
468
2
Laravel

Installing composer/laravel for the first time, minimum-stability issue

Posted 2 years ago by Axeia

Hello,

I'm new to both composer and laravel and I'm running into a problem with the very first step to getting started. I downloaded composer with:

curl -sS https://getcomposer.org/installer | php

then I tried to install laravel with the command

/usr/bin/composer.phar global require "laravel/composer"

But as I was getting this error:

Could not find package laravel/composer at any version for your minimum-stability (stable). Check the package spelling or your minimum-stability

I googled around a little bit and ended up running /usr/bin/composer.phar diag which mentioned composer.json FAIL and Checking pubkeys: FAIL along with a You are not running the latest stable version run composer-self-update to update etc etc. So as asked to do I ran /usr/bin/composer.phar self-update which ran fine.

I ran the diag again and only got a fail on Checking composer.json everything else checked out fine this time. Then I ran /usr/bin/composer.phar global require "laravel/composer" once more but got the same stability error as I got previously. Can I fix this with a command or do I need to create a JSON file in the home .composer/ directory and what should be in there?

PS: I have no desire to run the virtual machine even though it would be a lot more starter friendly, my server machine is short on resources

Please sign in or create an account to participate in this conversation.

Reply to

Use Markdown with GitHub-flavored code blocks.