I Have a Problem when Upgrade Laravel 5.7 from 5.6

Posted 11 months ago by zulham724

I Have this message after composer update

Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1 - laravelcollective/html v5.6.10 requires illuminate/view 5.6.* -> satisfiable by laravel/framework[v5.6.29], illuminate/view[5.6.x-dev, v5.6.0, v5.6.1, v5.6.10, v5.6.11, v5.6.12, v5.6.13, v5.6.14, v5.6.15, v5.6.16, v5.6.17, v5.6.19, v5.6.2, v5.6.20, v5.6.21, v5.6.22, v5.6.23, v5.6.24, v5.6.25, v5.6.26, v5.6.27, v5.6.28, v5.6.29, v5.6.3, v5.6.30, v5.6.31, v5.6.32, v5.6.33, v5.6.34, v5.6.35, v5.6.4, v5.6.5, v5.6.6, v5.6.7, v5.6.8, v5.6.9]. - laravelcollective/html 5.6.x-dev requires illuminate/view 5.6.* -> satisfiable by laravel/framework[v5.6.29], illuminate/view[5.6.x-dev, v5.6.0, v5.6.1, v5.6.10, v5.6.11, v5.6.12, v5.6.13, v5.6.14, v5.6.15, v5.6.16, v5.6.17, v5.6.19, v5.6.2, v5.6.20, v5.6.21, v5.6.22, v5.6.23, v5.6.24, v5.6.25, v5.6.26, v5.6.27, v5.6.28, v5.6.29, v5.6.3, v5.6.30, v5.6.31, v5.6.32, v5.6.33, v5.6.34, v5.6.35, v5.6.4, v5.6.5, v5.6.6, v5.6.7, v5.6.8, v5.6.9]. - laravelcollective/html 5.6.x-dev requires illuminate/view 5.6.* -> satisfiable by laravel/framework[v5.6.29], illuminate/view[5.6.x-dev, v5.6.0, v5.6.1, v5.6.10, v5.6.11, v5.6.12, v5.6.13, v5.6.14, v5.6.15, v5.6.16, v5.6.17, v5.6.19, v5.6.2, v5.6.20, v5.6.21, v5.6.22, v5.6.23, v5.6.24, v5.6.25, v5.6.26, v5.6.27, v5.6.28, v5.6.29, v5.6.3, v5.6.30, v5.6.31, v5.6.32, v5.6.33, v5.6.34, v5.6.35, v5.6.4, v5.6.5, v5.6.6, v5.6.7, v5.6.8, v5.6.9]. - laravelcollective/html v5.5.2 requires illuminate/view 5.6.* -> satisfiable by laravel/framework[v5.6.29], illuminate/view[5.6.x-dev, v5.6.0, v5.6.1, v5.6.10, v5.6.11, v5.6.12, v5.6.13, v5.6.14, v5.6.15, v5.6.16, v5.6.17, v5.6.19, v5.6.2, v5.6.20, v5.6.21, v5.6.22, v5.6.23, v5.6.24, v5.6.25, v5.6.26, v5.6.27, v5.6.28, v5.6.29, v5.6.3, v5.6.30, v5.6.31, v5.6.32, v5.6.33, v5.6.34, v5.6.35, v5.6.4, v5.6.5, v5.6.6, v5.6.7, v5.6.8, v5.6.9]. - laravelcollective/html v5.6 requires illuminate/view 5.6.* -> satisfiable by laravel/framework[v5.6.29], illuminate/view[5.6.x-dev, v5.6.0, v5.6.1, v5.6.10, v5.6.11, v5.6.12, v5.6.13, v5.6.14, v5.6.15, v5.6.16, v5.6.17, v5.6.19, v5.6.2, v5.6.20, v5.6.21, v5.6.22, v5.6.23, v5.6.24, v5.6.25, v5.6.26, v5.6.27, v5.6.28, v5.6.29, v5.6.3, v5.6.30, v5.6.31, v5.6.32, v5.6.33, v5.6.34, v5.6.35, v5.6.4, v5.6.5, v5.6.6, v5.6.7, v5.6.8, v5.6.9]. - laravelcollective/html v5.6.1 requires illuminate/view 5.6.* -> satisfiable by laravel/framework[v5.6.29], illuminate/view[5.6.x-dev, v5.6.0, v5.6.1, v5.6.10, v5.6.11, v5.6.12, v5.6.13, v5.6.14, v5.6.15, v5.6.16, v5.6.17, v5.6.19, v5.6.2, v5.6.20, v5.6.21, v5.6.22, v5.6.23, v5.6.24, v5.6.25, v5.6.26, v5.6.27, v5.6.28, v5.6.29, v5.6.3, v5.6.30, v5.6.31, v5.6.32, v5.6.33, v5.6.34, v5.6.35, v5.6.4, v5.6.5, v5.6.6, v5.6.7, v5.6.8, v5.6.9]. - laravelcollective/html v5.6.10 requires illuminate/view 5.6.* -> satisfiable by laravel/framework[v5.6.29], illuminate/view[5.6.x-dev, v5.6.0, v5.6.1, v5.6.10, v5.6.11, v5.6.12, v5.6.13, v5.6.14, v5.6.15, v5.6.16, v5.6.17, v5.6.19, v5.6.2, v5.6.20, v5.6.21, v5.6.22, v5.6.23, v5.6.24, v5.6.25, v5.6.26, v5.6.27, v5.6.28, v5.6.29, v5.6.3, v5.6.30, v5.6.31, v5.6.32, v5.6.33, v5.6.34, v5.6.35, v5.6.4, v5.6.5, v5.6.6, v5.6.7, v5.6.8, v5.6.9]. - laravelcollective/html v5.6.2 requires illuminate/view 5.6.* -> satisfiable by laravel/framework[v5.6.29], illuminate/view[5.6.x-dev, v5.6.0, v5.6.1, v5.6.10, v5.6.11, v5.6.12, v5.6.13, v5.6.14, v5.6.15, v5.6.16, v5.6.17, v5.6.19, v5.6.2, v5.6.20, v5.6.21, v5.6.22, v5.6.23, v5.6.24, v5.6.25, v5.6.26, v5.6.27, v5.6.28, v5.6.29, v5.6.3, v5.6.30, v5.6.31, v5.6.32, v5.6.33, v5.6.34, v5.6.35, v5.6.4, v5.6.5, v5.6.6, v5.6.7, v5.6.8, v5.6.9]. - laravelcollective/html v5.6.3 requires illuminate/view 5.6.* -> satisfiable by laravel/framework[v5.6.29], illuminate/view[5.6.x-dev, v5.6.0, v5.6.1, v5.6.10, v5.6.11, v5.6.12, v5.6.13, v5.6.14, v5.6.15, v5.6.16, v5.6.17, v5.6.19, v5.6.2, v5.6.20, v5.6.21, v5.6.22, v5.6.23, v5.6.24, v5.6.25, v5.6.26, v5.6.27, v5.6.28, v5.6.29, v5.6.3, v5.6.30, v5.6.31, v5.6.32, v5.6.33, v5.6.34, v5.6.35, v5.6.4, v5.6.5, v5.6.6, v5.6.7, v5.6.8, v5.6.9]. - laravelcollective/html v5.6.4 requires illuminate/view 5.6.* -> satisfiable by laravel/framework[v5.6.29], illuminate/view[5.6.x-dev, v5.6.0, v5.6.1, v5.6.10, v5.6.11, v5.6.12, v5.6.13, v5.6.14, v5.6.15, v5.6.16, v5.6.17, v5.6.19, v5.6.2, v5.6.20, v5.6.21, v5.6.22, v5.6.23, v5.6.24, v5.6.25, v5.6.26, v5.6.27, v5.6.28, v5.6.29, v5.6.3, v5.6.30, v5.6.31, v5.6.32, v5.6.33, v5.6.34, v5.6.35, v5.6.4, v5.6.5, v5.6.6, v5.6.7, v5.6.8, v5.6.9]. - laravelcollective/html v5.6.5 requires illuminate/view 5.6.* -> satisfiable by laravel/framework[v5.6.29], illuminate/view[5.6.x-dev, v5.6.0, v5.6.1, v5.6.10, v5.6.11, v5.6.12, v5.6.13, v5.6.14, v5.6.15, v5.6.16, v5.6.17, v5.6.19, v5.6.2, v5.6.20, v5.6.21, v5.6.22, v5.6.23, v5.6.24, v5.6.25, v5.6.26, v5.6.27, v5.6.28, v5.6.29, v5.6.3, v5.6.30, v5.6.31, v5.6.32, v5.6.33, v5.6.34, v5.6.35, v5.6.4, v5.6.5, v5.6.6, v5.6.7, v5.6.8, v5.6.9]. - laravelcollective/html v5.6.6 requires illuminate/view 5.6.* -> satisfiable by laravel/framework[v5.6.29], illuminate/view[5.6.x-dev, v5.6.0, v5.6.1, v5.6.10, v5.6.11, v5.6.12, v5.6.13, v5.6.14, v5.6.15, v5.6.16, v5.6.17, v5.6.19, v5.6.2, v5.6.20, v5.6.21, v5.6.22, v5.6.23, v5.6.24, v5.6.25, v5.6.26, v5.6.27, v5.6.28, v5.6.29, v5.6.3, v5.6.30, v5.6.31, v5.6.32, v5.6.33, v5.6.34, v5.6.35, v5.6.4, v5.6.5, v5.6.6, v5.6.7, v5.6.8, v5.6.9]. - laravelcollective/html v5.6.7 requires illuminate/view 5.6.* -> satisfiable by laravel/framework[v5.6.29], illuminate/view[5.6.x-dev, v5.6.0, v5.6.1, v5.6.10, v5.6.11, v5.6.12, v5.6.13, v5.6.14, v5.6.15, v5.6.16, v5.6.17, v5.6.19, v5.6.2, v5.6.20, v5.6.21, v5.6.22, v5.6.23, v5.6.24, v5.6.25, v5.6.26, v5.6.27, v5.6.28, v5.6.29, v5.6.3, v5.6.30, v5.6.31, v5.6.32, v5.6.33, v5.6.34, v5.6.35, v5.6.4, v5.6.5, v5.6.6, v5.6.7, v5.6.8, v5.6.9]. - laravelcollective/html v5.6.8 requires illuminate/view 5.6.* -> satisfiable by laravel/framework[v5.6.29], illuminate/view[5.6.x-dev, v5.6.0, v5.6.1, v5.6.10, v5.6.11, v5.6.12, v5.6.13, v5.6.14, v5.6.15, v5.6.16, v5.6.17, v5.6.19, v5.6.2, v5.6.20, v5.6.21, v5.6.22, v5.6.23, v5.6.24, v5.6.25, v5.6.26, v5.6.27, v5.6.28, v5.6.29, v5.6.3, v5.6.30, v5.6.31, v5.6.32, v5.6.33, v5.6.34, v5.6.35, v5.6.4, v5.6.5, v5.6.6, v5.6.7, v5.6.8, v5.6.9]. - laravelcollective/html v5.6.9 requires illuminate/view 5.6.* -> satisfiable by laravel/framework[v5.6.29], illuminate/view[5.6.x-dev, v5.6.0, v5.6.1, v5.6.10, v5.6.11, v5.6.12, v5.6.13, v5.6.14, v5.6.15, v5.6.16, v5.6.17, v5.6.19, v5.6.2, v5.6.20, v5.6.21, v5.6.22, v5.6.23, v5.6.24, v5.6.25, v5.6.26, v5.6.27, v5.6.28, v5.6.29, v5.6.3, v5.6.30, v5.6.31, v5.6.32, v5.6.33, v5.6.34, v5.6.35, v5.6.4, v5.6.5, v5.6.6, v5.6.7, v5.6.8, v5.6.9]. - laravelcollective/html 5.4.x-dev requires illuminate/view 5.4.* -> satisfiable by illuminate/view[5.4.x-dev, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9]. - laravelcollective/html v5.4 requires illuminate/view 5.4.* -> satisfiable by illuminate/view[5.4.x-dev, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9]. - laravelcollective/html v5.4.1 requires illuminate/view 5.4.* -> satisfiable by illuminate/view[5.4.x-dev, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9]. - laravelcollective/html v5.4.2 requires illuminate/view 5.4.* -> satisfiable by illuminate/view[5.4.x-dev, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9]. - laravelcollective/html v5.4.3 requires illuminate/view 5.4.* -> satisfiable by illuminate/view[5.4.x-dev, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9]. - laravelcollective/html v5.4.4 requires illuminate/view 5.4.* -> satisfiable by illuminate/view[5.4.x-dev, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9]. - laravelcollective/html v5.4.5 requires illuminate/view 5.4.* -> satisfiable by illuminate/view[5.4.x-dev, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9]. - laravelcollective/html v5.4.6 requires illuminate/view 5.4.* -> satisfiable by illuminate/view[5.4.x-dev, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9]. - laravelcollective/html v5.4.7 requires illuminate/view 5.4.* -> satisfiable by illuminate/view[5.4.x-dev, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9]. - laravelcollective/html v5.4.8 requires illuminate/view 5.4.* -> satisfiable by illuminate/view[5.4.x-dev, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9]. - laravelcollective/html v5.4.9 requires illuminate/view 5.4.* -> satisfiable by illuminate/view[5.4.x-dev, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9]. - laravelcollective/html 5.5.x-dev requires illuminate/view 5.5.* -> satisfiable by illuminate/view[5.5.x-dev, v5.5.0, v5.5.16, v5.5.17, v5.5.2, v5.5.28, v5.5.33, v5.5.34, v5.5.35, v5.5.36, v5.5.37, v5.5.39, v5.5.40, v5.5.41]. - laravelcollective/html v5.5 requires illuminate/view 5.5.* -> satisfiable by illuminate/view[5.5.x-dev, v5.5.0, v5.5.16, v5.5.17, v5.5.2, v5.5.28, v5.5.33, v5.5.34, v5.5.35, v5.5.36, v5.5.37, v5.5.39, v5.5.40, v5.5.41]. - laravelcollective/html v5.5.1 requires illuminate/view 5.5.* -> satisfiable by illuminate/view[5.5.x-dev, v5.5.0, v5.5.16, v5.5.17, v5.5.2, v5.5.28, v5.5.33, v5.5.34, v5.5.35, v5.5.36, v5.5.37, v5.5.39, v5.5.40, v5.5.41]. - laravelcollective/html v5.5.3 requires illuminate/view 5.5.* -> satisfiable by illuminate/view[5.5.x-dev, v5.5.0, v5.5.16, v5.5.17, v5.5.2, v5.5.28, v5.5.33, v5.5.34, v5.5.35, v5.5.36, v5.5.37, v5.5.39, v5.5.40, v5.5.41]. - laravelcollective/html v5.5.4 requires illuminate/view 5.5.* -> satisfiable by illuminate/view[5.5.x-dev, v5.5.0, v5.5.16, v5.5.17, v5.5.2, v5.5.28, v5.5.33, v5.5.34, v5.5.35, v5.5.36, v5.5.37, v5.5.39, v5.5.40, v5.5.41]. - Can only install one of: laravel/framework[5.7.x-dev, v5.6.29]. - don't install illuminate/view 5.6.x-dev|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.0|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.1|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.10|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.11|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.12|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.13|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.14|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.15|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.16|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.17|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.19|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.2|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.20|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.21|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.22|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.23|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.24|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.25|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.26|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.27|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.28|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.29|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.3|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.30|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.31|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.32|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.33|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.34|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.35|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.4|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.5|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.6|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.7|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.8|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.6.9|don't install laravel/framework 5.7.x-dev - don't install illuminate/view 5.4.x-dev|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.4.0|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.4.13|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.4.17|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.4.19|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.4.27|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.4.36|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.4.9|don't install laravel/framework 5.7.x-dev - don't install illuminate/view 5.5.x-dev|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.5.0|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.5.16|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.5.17|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.5.2|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.5.28|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.5.33|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.5.34|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.5.35|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.5.36|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.5.37|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.5.39|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.5.40|don't install laravel/framework 5.7.x-dev - don't install illuminate/view v5.5.41|don't install laravel/framework 5.7.x-dev - Installation request for laravel/framework 5.7.* -> satisfiable by laravel/framework[5.7.x-dev]. - Installation request for laravelcollective/html ^5.4.0 -> satisfiable by laravelcollective/html[5.4.x-dev, 5.5.x-dev, 5.6.x-dev, v5.4, v5.4.1, v5.4.2, v5.4.3, v5.4.4, v5.4.5, v5.4.6, v5.4.7, v5.4.8, v5.4.9, v5.5, v5.5.1, v5.5.2, v5.5.3, v5.5.4, v5.6, v5.6.1, v5.6.10, v5.6.2, v5.6.3, v5.6.4, v5.6.5, v5.6.6, v5.6.7, v5.6.8, v5.6.9].

and laravel version still 5.6.*

Please sign in or create an account to participate in this conversation.