bballantyne
1 month ago
148
3
Laravel

Horizon doesn't read jobs from Redis

Posted 1 month ago by bballantyne

I need some guidance please. I've read all the Horizon-related questions but I still can't pinpoint the source of my issue.

I have Horizon installed on one server, redis-server on another and another Laravel project for my users on a third server.

The Horizon dashboard is active. In my current setup I didn't setup supervisor as yet, but I do have the horizon worker running.

On the Horizon project, my horizon.php:

'environments' => [
        'production' => [
            'supervisor-1' => [
                'connection' => 'redis',
                'queue' => ['default', 'prods'],
                'balance' => 'simple',
                'processes' => 10,
                'tries' => 1,
            ],
        ],

        'local' => [
            'supervisor-1' => [
                'connection' => 'redis',
                'queue' => ['default', 'tests'],
                'balance' => 'simple',
                'processes' => 3,
                'tries' => 1,
            ],
        ],
    ],

...my queue.php contains:

'redis' => [
            'driver' => 'redis',
            'connection' => 'default',
            'queue' => env('REDIS_QUEUE', 'default'),
            'retry_after' => 90,
            'block_for' => null,
        ],

and the .env has

QUEUE_CONNECTION=redis

In my other Laravel app from where the jobs are dispatched, the queue.php and .env contain the same snippets as above. In this app, I have the queue worker running as

php artisan queue:work redis

However, the Horizon dashboard always shows 0 jobs.

I'd be happy to share any other details if anyone is able to point me in at least a general direction.

Please sign in or create an account to participate in this conversation.