torriv
1 week ago

Homestead with type NFS not working

Posted 1 week ago by torriv
windows 10 pro
Laravel/homestead version: 9.3.0
VirtualBox version: 6.0
Vagrant version: 2.2.6

i've been trying to fix this this whole day now and can't figure it out.

i had all my projects in one homestead environment, and everything worked fine. But i decided to go for "per projects" installation instead of homestead.

i've got all projects up and running. But i can't get NFS to work. (it worked when i had all projects under same homestead).

i've tried many tutorials and suggestions i could find on google...

i've successfully installed vagrant-winnfsd plugin. and i set det settings in "homestead.yaml" to

folders:
    -
        map: 'path\to\project'
        to: /home/vagrant/code
        type: "nfs"

the Error i get when i try to vagrant up --provision is:

................
==> bpa: Exporting NFS shared folders...
==> bpa: Preparing to edit nfs mounting file.
[NFS] Status: halted
[NFS] Start: started
==> bpa: Mounting NFS shared folders...
The following SSH command responded with a non-zero exit status.
Vagrant assumes that this means the command failed!

mount -o vers=3,udp,actimeo=1,nolock 192.168.10.1:/D/SynologyDrive/Prosjekter/Privat/bpa /home/vagrant/code

Stdout from the command:



Stderr from the command:

mount.nfs: an incorrect mount option was specified

Does anyone have any suggestions to what can be wrong or how to fix this?

Please sign in or create an account to participate in this conversation.