kordix
249
2
Laravel

Heroku whoopsing

Posted 1 year ago by kordix

I uploaded application on heroku, I see the site but I can't do anything with database. Probably.

I can't register new user, whhops, looks something went wrong.

I have database set up. Php artisan migrate and refresh went fine. It is external database and I checked if it done refresh in phpmyadmin database (I moved data to external base from localhost manually). So I see credentials in .env are good.

But what is interesting it worked only from localhost. When I run heroku bash and then migrate, there is error SQLSTATE[HY000] [2002] Connection refused

When I run key generate on heroku bash there is file_get_contents(/app/.env): failed to open stream: No such file or directory

P.S I turned on debug mode in app.php , I also tried this https://laracasts.com/discuss/channels/laravel/whoops-looks-like-something-went-wrong-when-pushing-to-heroku

Now it shows typical whoops error with same information SQLSTATE[HY000] [2002] Connection refused

Please sign in or create an account to participate in this conversation.