ristlin
6 months ago

Having trouble upgrading Sentry with Laravel 5.8

Posted 6 months ago by ristlin

When I attempt to require sentry/sentry-laravel I get the following errors:

In OptionsResolver.php line 747:
                                                                               
  The option "user_context" does not exist. Defined options are: "attach_stac  
  ktrace", "before_breadcrumb", "before_send", "capture_silenced_errors", "co  
  ntext_lines", "default_integrations", "dsn", "enable_compression", "environ  
  ment", "error_types", "excluded_exceptions", "http_proxy", "in_app_exclude"  
  , "integrations", "logger", "max_breadcrumbs", "max_value_length", "prefixe  
  s", "project_root", "release", "sample_rate", "send_attempts", "send_defaul  
  t_pii", "server_name", "tags".                                               
                                                                               

Then this one:

Script @php artisan package:discover handling the post-autoload-dump event returned with error code 1

Has anyone been able to install Sentry-Laravel 1.0 on a migrated Laravel app?

I've tried the suggestions here to remove and flush out the cache and config, but still having issues: https://github.com/getsentry/sentry-laravel/issues/185

Please sign in or create an account to participate in this conversation.