Conflict between Eloquence and Sluggable packages

Posted 2 years ago by SergioGregorutti

Hi everyone,

I'm using both packages (Eloquence and Sluggable) in my project with Laravel 5.2 and it seems like there's a blocker issue.

I get this error on my models:

Trait method replicate has not been applied, because there are collisions with other trait methods on App\User

This is because both packages have a "replicate" method and there's a conflict. I know that the solution is something related to this: http://php.net/manual/en/language.oop5.traits.php#language.oop5.traits.conflict

But, with my experience I don't know how to apply that solution. Can someone help me on this?

Thanks in advance!

Please sign in or create an account to participate in this conversation.

Reply to

Use Markdown with GitHub-flavored code blocks.