wljin
2552
7
Laravel

Laravel 5.3 blank white screen no errors

Posted 2 years ago by wljin

I have gone through so many forums trying to find a solution to fix this error but non seems to be working. I have assigned

sudo chown -R www-data:www-data /path/directory 

results for ls -al

drwxrwxrwx 12 www-data www-data    4096 Oct 25 10:06 .
drwxrwxrwx  6 www-data www-data    4096 Oct 25 06:46 ..
drwxr-xr-x  6 www-data www-data    4096 Oct 25 10:04 app
-rw-r--r--  1 www-data www-data    1646 Oct 25 10:04 artisan
drwxr-xr-x  3 www-data www-data    4096 Oct 25 10:04 bootstrap
-rw-r--r--  1 www-data www-data    1412 Oct 25 10:04 composer.json
-rw-r--r--  1 www-data www-data  134388 Oct 25 10:04 composer.lock
-rw-r--r--  1 www-data www-data 1723068 Oct 25 10:04 composer.phar
drwxr-xr-x  2 www-data www-data    4096 Oct 25 10:04 config
drwxr-xr-x  5 www-data www-data    4096 Oct 25 10:04 database
-rw-r--r--  1 www-data www-data     615 Oct 25 09:46 .env
-rw-r--r--  1 www-data www-data     491 Oct 25 10:04 .env.example
-rw-r--r--  1 www-data www-data      61 Oct 25 10:04 .gitattributes
-rw-r--r--  1 www-data www-data      96 Oct 25 10:04 .gitignore
-rw-r--r--  1 www-data www-data     558 Oct 25 10:04 gulpfile.js
-rw-r--r--  1 www-data www-data     135 Oct 25 07:17 .htaccess
-rw-r--r--  1 www-data www-data  401057 Oct 25 10:04 _ide_helper.php
-rw-r--r--  1 www-data www-data     401 Oct 25 10:04 package.json
-rw-r--r--  1 www-data www-data     930 Oct 25 10:04 phpunit.xml
drwxr-xr-x  5 www-data www-data    4096 Oct 25 10:04 public
-rw-r--r--  1 www-data www-data     749 Oct 25 10:04 readme.md
drwxr-xr-x  5 www-data www-data    4096 Oct 25 10:04 resources
drwxr-xr-x  2 www-data www-data    4096 Oct 25 10:04 routes
-rw-r--r--  1 www-data www-data     563 Oct 25 10:04 server.php
drwxrwxrwx  5 www-data www-data    4096 Oct 25 10:04 storage
drwxr-xr-x  2 www-data www-data    4096 Oct 25 10:04 tests
drwxr-xr-x 34 www-data www-data    4096 Oct 25 10:06 vendor

I also applied

sudo chgrp -R www-data storage bootstrap/cache
sudo chmod -R ug+rwx storage bootstrap/cache

but am still getting the black white screen. where am i going wrong

Please sign in or create an account to participate in this conversation.