blada dont show http

Published 7 months ago by haizone

hi in my DB i have a URL like this: http://google.com

but in the blada its show to me: //google.com/

someone know how to fix that?

Best Answer (As Selected By haizone)
haizone

I found the problem This https://github.com/renatomarinho/laravel-page-speed/blob/master/README.md

Do the problem So I comment that line RenatoMarinho\LaravelPageSpeed\Middleware\TrimUrls::class,

And it’s works Thanks for the helps

haizone

i try is sty the same and i try olso {{url($website) }}

donst work :/

haizone

if id dd() i see the http:// but in the blada i dont see

danielrubango

Just use {{ $website }}

haizone

@danielrubango is show to me //google.com/

without the http://

danielrubango

How do you try to echo out the content of your $website variable ? Can you show us your blade file ?

haizone

@danielrubango i have a input from controller $business

and i try to get out the url from the db: show here: https://codepen.io/anon/pen/paLZdm

     <div class="form-group">
       <label class="control-label col-sm-2" for="website">URL:</label>
       <div class="col-sm-10">
         <input type="text" class="form-control" id="website" name="website"
         placeholder="url" value="{{$business->website}}">
       </div>

and i try {!!$business->website!!} {{url($business->website)}}

n my DB i have a URL like this: http://google.com

but in the blada its show to me: //google.com/

danielrubango

I try that locally, and it works.

Try doing

{{ $business->website }}

It has to work, if not, show us your blade file and maybe your controller file, where you do the work.

haizone

I try local I don’t now why is didn’t work

danielrubango

@haizone Try, please to clear cache with php artisan clear:cache

haizone

I found the problem This https://github.com/renatomarinho/laravel-page-speed/blob/master/README.md

Do the problem So I comment that line RenatoMarinho\LaravelPageSpeed\Middleware\TrimUrls::class,

And it’s works Thanks for the helps

Snapey
Snapey
6 months ago (995,105 XP)

HTML doesn't need 'optimising' thats ridiculous.

Most people would blow any savings made just with a single wrong sized png or jpg.

Please sign in or create an account to participate in this conversation.