dxladner
2 months ago
715
13
General

ZSH on Mac, does not install PHP Packages using Composer since update to Catalina 10.15.5

Posted 2 months ago by dxladner

Here is my Mac setup. I am running MAMP 5.7 I also have iTerm 2 w/ zsh installed. Everything was running fine before update.

I had to restart my macbook which then went into a software update. So it updated to 10.15.5 Catalina.

Now, when I am in the terminal, either iTerm 2 zsh, PHP Storm, or Visual Studio Code. my terminal will not run composer install or composer update. It just sits there. No errors. It starts, I get the normal starting line

Loading composer repositories with package information Updating dependencies (including require-dev)

But nothing happens.

In iTerm2 I have the correct PHP path which is /Applications/MAMP/bin/php/php7.4.2/bin/php composer path is correct: /usr/local/bin/composer

I have ran composer clear-cache.

Nothing is working.

Ran composer diagnose. Everything is good. All green OK.

Any help would be greatly appreciated.

I also tried the verbose flag and the same.

Please sign in or create an account to participate in this conversation.