Sequel Pro stops working after running Migration successfully

Published 3 weeks ago by huuvan20

Hi, I'm working on Laravel 5.5, the development environment is Laradock & Sequel Pro is about to connect to a MySQL server on Laradock.

The weird thing is that after I run the migration command which is $ php artisan migrate

Tables were created successfully (I have accessed to mySQL server & checked. Even the Laravel app could write & read records properly).

Then I turn to Sequel Pro to have a better manage the DB but I cannot access the database. My DB is odot & whenever I click on it to access, the Sequel Pro is about to show a popup to ask me sending feedback to them & keep loading data (not showing data at all).

As I have experienced so far, this is not corrupt the DB. It is just super inconvenient to work with DB using UI like Sequel Pro.

P/s: I have tried to access that same DB using MySQL Workbench but no hopes. This corrupts the MySQL Workbench also. To guess this, maybe the Laradock is the cause. Thanks for your supports in advance.

huuvan20

Please ask for more details of the issue, I'm very much urgent for this, many thanks

ejdelmonico

You will need to check the port that Laradock is running the DB instance on. It appears that Laradock has mysql running on the standard port of 3306 in production but I couldn't find any documentation on the dev port used by docker.

huuvan20

There are port config I found in .env in laradock which is 3306. I have tested around to change it to 3308 then connect again, Sequel pro did connect to DB but keep loading infinitely when I click on the odot DB. So for odot, I cannot work on it at all, just loading...

ejdelmonico

hmm, that seems odd. I never had any issues with Sequel Pro. Maybe try MySQL Workbench and see if you can connect. If you use JetBrains products, DataGrip is easy to connect and works well.

huuvan20

I just tried the DataGrip, it's working properly, I can manage to work with records, it seems to be okay. Thanks @ejdelmonico I'm still confused why Sequel Pro not working properly, I suppose to re-install it to check again.

Please sign in or create an account to participate in this conversation.