piljac1
2 weeks ago

One valet linked website encounters a 404 while others don't

Posted 2 weeks ago by piljac1

Hi guys, I had a big head-scratcher today while trying to help a collegue out. We inherited a Joomla based website lately and today, I've been in charge of gitting the project and elaborate a doc on how to setup the project locally, because it's pretty much the first Joomla base web site that we have to work on.

I've been successfully able to set a local instance on my machine, but my collegue encountered an issue, which I think is purely valet related. I assume that because I've been able to link the website folder without any issues on my side, but it has been another story on her side.

Despite having multiple working valet linked projects of all types (Laravel, Wordpress, framework-less, etc.), she wasn't able to create a working link with this new website folder (which is in the same parent folder as her other websites). She encountered a 404 - Not found error.

I've tried to debug it for an hour and a half trying to avoid purging her .valet folder so she doesn't lose all of her already existing and working links, but without any luck.

I've tried unlinking and re-linking, valet park in the non-working website directory, restart valet, restart all brew services, reboot the computer, uninstalling Valet and re-installing it... Nothing works !

My next step would be to purge the .valet and /usr/local/bin/valet folders, but I'm wondering if I forgot a debug step before proceeding to this solution.

Please sign in or create an account to participate in this conversation.