codenihal
5 years ago

Laravel Socialite installation error

Posted 5 years ago by codenihal

I'm trying to install Laravel Socialite and I copied jeffrey's composer.json.

I get these errors

  Problem 1
    - laravel/socialite v1.0.3 requires illuminate/contracts ~4.3 -> no matching package found.
    - laravel/socialite v1.0.2 requires illuminate/contracts ~4.3 -> no matching package found.
    - laravel/socialite v1.0.1 requires illuminate/contracts ~4.3 -> no matching package found.
    - laravel/socialite v1.0.0 requires illuminate/contracts ~4.3 -> no matching package found.
    - laravel/socialite 1.0.x-dev requires illuminate/contracts ~4.3 -> no matching package found.
    - Installation request for laravel/socialite ~1.0 -> satisfiable by laravel/socialite[1.0.x-dev, v1.0.0, v1.0.1, v1.0.2, v1.0.3].
</pre></code>

My Require Block in composer.json looks like this 
<code><pre>
 "require": {
        "laravel/framework": "4.3.*",
        "laravel/socialite": "~1.0",
        "illuminate/html": "~4.0",
        "way/generators": "~3.0",
        "phpspec/phpspec": "~2.0"
    },

How in the world do I fix this, please help me..?

Please sign in or create an account to participate in this conversation.