martin
4 years ago
63
27
General

HttpNotFoundException although route exists

Posted 4 years ago by martin

I have a Laravel site set up on my macBook, everything works fine - I can add routes and controllers, etc.

I'm trying to teach Laravel and have set up a stand alone machine (not connected to a network) in the lecture room similar to what I have on my mac (we don't have macs in the lecture room) -the only difference in setup is the lecture room machine has Ubuntu. All fine (Vagrant, Homestead,etc), except for:

When I add to the routes.php file or edit any views it is like laraval is not recognising the change of the files in the text editor.

I've tried simply copying the working version of the program from my macBook (which works fine) to the Ubuntu machine, adding a route, and the same happens - HttpNotFoundException.

I've tried clear:compiled and clear:cache (syntax may not be right here but I ran them successfully).

I've allowed permissions on the resources folder. It seems as if something is 'locked down' that I'm not aware of, or its something to do with Ubuntu. As both versions are running through Ubuntu on Vagrant though that shouldn't happen though, should it?

Has anyone had a similar problem, or does anyone know what is causing this?

thanks in advance

(great site and lessons Jeffrey - thanks for what you do - I know how long it takes to prepare lessons and the level of knowledge you need to have to be able to teach successfully - thanks)

Martin Rowe

Please sign in or create an account to participate in this conversation.