saurabhd

In config/auth.php file you need to change driver like :


'providers' => [
        'users' => [
            'driver' => 'eloquent',
            'model' => App\Models\Users\User::class,
        ],

Hope this solution useful for you !

babind

I have already done this ..but its not helping me

babind

After Doing trial and error.

Web.php
    Auth::routes();
    Route::get('/home', '[email protected]');
babind

config/auth.php

return [

'defaults' => [
    'guard' => 'web',
    'passwords' => 'users',
],


'guards' => [
    'web' => [
        'driver' => 'session',
        'provider' => 'users',
    ],

    'api' => [
        'driver' => 'token',
        'provider' => 'users',
    ],
],


'providers' => [
    'users' => [
        'driver' => 'eloquent',
        'model' => App\Models\Users\User::class,
    ],
   
    // 'users' => [
    //     'driver' => 'database',
    //     'table' => 'users',
    // ],
],

'passwords' => [
    'users' => [
        'provider' => 'users',
        'table' => 'password_resets',
        'expire' => 60,
    ],
  ],

  ];
babind

Not working one( time waste) config/auth.php

return [

'defaults' => [
    'guard' => 'web',
    'passwords' => 'users',
],


'guards' => [
    'web' => [
        'driver' => 'session',
        'provider' => 'users',
    ],

    'api' => [
        'driver' => 'token',
        'provider' => 'users',
    ],
],


'providers' => [
    'users' => [
        'driver' => 'eloquent',
        'model' => App\Models\Users\User::class,
    ],

    'users' => [
        'driver' => 'database',
        'table' => 'users',
    ],
],

'passwords' => [
    'users' => [
        'provider' => 'users',
        'table' => 'password_resets',
        'expire' => 60,
    ],
],

];

Please sign in or create an account to participate in this conversation.