HttpFoundation\ParameterBag not found http-foundation/Request

Published 6 days ago by JasperK

My L5 applicaties gets an error after doing composer install:

( ! ) Fatal error: Uncaught Error: Class 'Symfony\Component\HttpFoundation\ParameterBag' not found in /home/vagrant/Code/vendor/symfony/http-foundation/Request.php on line 238
( ! ) Error: Class 'Symfony\Component\HttpFoundation\ParameterBag' not found in /home/vagrant/Code/vendor/symfony/http-foundation/Request.php on line 238

It's probably a Homestead problem, because it's working on one Homestead instance and not at another. Both on the same versions of Homestead on MacOS.

Anyone an idea how to fix this?

bobbybouwmann

Can you try to delete your vendor directory and run composer install again. That class is part of symfony and should always be there!

JasperK

Been there, done that. Fixed it by copying the vendor folder manually from the working to the non working pc.

bobbybouwmann

Have you tried running composer update or removing your composer.lock file. It could be something in there!

Please sign in or create an account to participate in this conversation.