Homestead updating

Posted 9 months ago by Mattiman

So, like every six months or so I'm back asking for help fixing Homestead update problems. From the last time I asked I have had this list of command I run to update. It worked for a couple of times:

Download and install latest VirtualBox
Download and install latest vagrant
Update box and repo Homestead:
$ cd ~/Homestead
$ git fetch origin
$ git checkout v7.1.0 // whichever tag is released
$ vagrant box update
$ vagrant destroy
$ rm -rf .vagrant
$ vagrant up

But today I tried this again but I get this:

$ cd ~/Homestead
$ git fetch origin
remote: Counting objects: 15, done.
remote: Compressing objects: 100% (5/5), done.
remote: Total 15 (delta 8), reused 14 (delta 8), pack-reused 0
Unpacking objects: 100% (15/15), done.
   4ee5e98..9f36545  master     -> origin/master
 * [new tag]         v7.3.0     -> v7.3.0
 * [new tag]         v7.2.0     -> v7.2.0
$ git checkout v7.3.0
Previous HEAD position was 4ee5e98... ? ? Update version to 7.1.2
HEAD is now at 9f36545... ❄️ ? ? Require box v5.2.x and tag v7.3.0
$ vagrant box update
==> homestead-7: Box 'laravel/homestead' not installed, can't check for updates.

So why do I get this message? I certainly have Homestead installed. And what can I do now?

Please sign in or create an account to participate in this conversation.

Laracasts Mascot

Hi, Have We Met Yet?

Did you know that, in addition to the forum, Laracasts includes well over 1000 lessons on modern web development? All for the price of one lunch out per month.

Sign Me Up


Reply to

Use Markdown with GitHub-flavored code blocks.