mgmk
204
3
General

Composer update not install latest version

Posted 2 years ago by mgmk

I'm using laravel-datatable-oracle package in my website. So in my composer.json the format is like that

"yajra/laravel-datatables-oracle": "~6.0"

At the moment this package has updated to 6.22.2 officially. So I run "composer update" to get latest version. But it was only updated to version "6.17.0", not to latest one "6.22.2".

As I understood from composer VCS, ~6.0 means get the latest package between >=6.0 and <7.0. But I don't know why "composer update" is only update to "6.17.0".

Can anyone explain me what I was wrong in this scenarios?

Please sign in or create an account to participate in this conversation.

Reply to

Use Markdown with GitHub-flavored code blocks.