Composer update fails

Posted 3 years ago by mtvs_dev

I just want to install a new package but when I run composer update package/package it fails because of the requirements of another package.

How can I skip this?

php composer.phar update guzzlehttp/guzzle

Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - mccool/laravel-auto-presenter 3.0.0 requires php >=5.5.0 -> your PHP version (5.4.45-1+deb.sury.org~precise+1) or "config.platform.php" value does not satisfy that requirement.
    - mccool/laravel-auto-presenter 3.0.0 requires php >=5.5.0 -> your PHP version (5.4.45-1+deb.sury.org~precise+1) or "config.platform.php" value does not satisfy that requirement.
    - mccool/laravel-auto-presenter 3.0.0 requires php >=5.5.0 -> your PHP version (5.4.45-1+deb.sury.org~precise+1) or "config.platform.php" value does not satisfy that requirement.
    - Installation request for mccool/laravel-auto-presenter == 3.0.0.0 -> satisfiable by mccool/laravel-auto-presenter[3.0.0].

Please sign in or create an account to participate in this conversation.

Reply to

Use Markdown with GitHub-flavored code blocks.