Qlic
3 years ago

Composer gives me an error

Posted 3 years ago by Qlic

Hi guys,

I am trying to update a project through composer, but it gives me an error i have not encoutered before.

- Updating league/csv dev-master (69bafa6 => 0a1b535)


                                                                 
  [RuntimeException]                                             
  Failed to execute git status --porcelain --untracked-files=no  
  'git' is not recognized as an internal or external command,    
  operable program or batch file.     

I updated composer itself, tried dump-autoload, i even tried it on a different computer, but i get the same error. Her is my composer.json.

{
    "name": "laravel/laravel",
    "description": "The Laravel Framework.",
    "keywords": ["framework", "laravel"],
    "license": "MIT",
    "type": "project",
    "require": {
        "php": ">=5.5.9",
        "laravel/framework": "5.1.*",
        "league/csv": "dev-master",
        "baum/baum": "dev-master",
        "giggsey/libphonenumber-for-php": "dev-master",
        "barryvdh/laravel-ide-helper": "dev-master",
        "illuminate/html": "dev-master",
        "laracasts/presenter": "dev-master",
        "barryvdh/laravel-dompdf": "dev-master",
        "chumper/zipper": "dev-master",
        "maatwebsite/excel": "dev-master",
        "laracasts/flash": "dev-master"
    },
    "require-dev": {
        "fzaninotto/faker": "~1.4",
        "mockery/mockery": "0.9.*",
        "phpunit/phpunit": "~4.0",
        "phpspec/phpspec": "~2.1"
    },
    "autoload": {
        "classmap": [
            "database",
            "app/Models",
            "app/Presenters"
        ],
        "psr-4": {
            "App\\": "app/"
        },
        "files": [
            "app/helpers.php"
        ]
    },
    "autoload-dev": {
        "classmap": [
            "tests/TestCase.php"
        ]
    },
    "scripts": {
        "post-install-cmd": [
            "php artisan clear-compiled",
            "php artisan optimize"
        ],
        "pre-update-cmd": [
            "php artisan clear-compiled"
        ],
        "post-update-cmd": [
            "php artisan optimize"
        ],
        "post-root-package-install": [
            "php -r \"copy('.env.example', '.env');\""
        ],
        "post-create-project-cmd": [
            "php artisan key:generate"
        ]
    },
    "config": {
        "preferred-install": "dist"
    }
}

Anyone knows how to fix this?

Please sign in or create an account to participate in this conversation.