Composer error with league/flysystem-aws-s3-v3 ~1.0

Posted 3 years ago by SergioGregorutti

Hi,

Im trying to install the league/flysystem-aws-s3-v3 ~1.0 to use the Laravel Filesystem.

But when I hit the "composer require league/flysystem-aws-s3-v3 ~1.0" I get this error:

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - league/flysystem-aws-s3-v3 1.0.0 requires aws/aws-sdk-php 3.*@dev -> satisfiable by aws/aws-sdk-php[3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 3.0.5, 3.0.6, 3.0.7, 3.1.0, 3.2.0, 3.2.1, 3.2.2, 3.2.3, 3.2.4, 3.2.5, 3.2.6, 3.3.0, 3.3.1, 3.3.2, 3.3.3, 3.3.4, 3.3.5].
    - league/flysystem-aws-s3-v3 1.0.1 requires aws/aws-sdk-php ^3.0.0 -> satisfiable by aws/aws-sdk-php[3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 3.0.5, 3.0.6, 3.0.7, 3.1.0, 3.2.0, 3.2.1, 3.2.2, 3.2.3, 3.2.4, 3.2.5, 3.2.6, 3.3.0, 3.3.1, 3.3.2, 3.3.3, 3.3.4, 3.3.5].
    - league/flysystem-aws-s3-v3 1.0.2 requires aws/aws-sdk-php ^3.0.0 -> satisfiable by aws/aws-sdk-php[3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 3.0.5, 3.0.6, 3.0.7, 3.1.0, 3.2.0, 3.2.1, 3.2.2, 3.2.3, 3.2.4, 3.2.5, 3.2.6, 3.3.0, 3.3.1, 3.3.2, 3.3.3, 3.3.4, 3.3.5].
    - league/flysystem-aws-s3-v3 1.0.3 requires aws/aws-sdk-php ^3.0.0 -> satisfiable by aws/aws-sdk-php[3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 3.0.5, 3.0.6, 3.0.7, 3.1.0, 3.2.0, 3.2.1, 3.2.2, 3.2.3, 3.2.4, 3.2.5, 3.2.6, 3.3.0, 3.3.1, 3.3.2, 3.3.3, 3.3.4, 3.3.5].
    - league/flysystem-aws-s3-v3 1.0.4 requires aws/aws-sdk-php ^3.0.0 -> satisfiable by aws/aws-sdk-php[3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 3.0.5, 3.0.6, 3.0.7, 3.1.0, 3.2.0, 3.2.1, 3.2.2, 3.2.3, 3.2.4, 3.2.5, 3.2.6, 3.3.0, 3.3.1, 3.3.2, 3.3.3, 3.3.4, 3.3.5].
    - aws/aws-sdk-php 3.3.5 requires guzzlehttp/guzzle ~5.3|~6.0.1|~6.1 -> no matching package found.
    - aws/aws-sdk-php 3.3.4 requires guzzlehttp/guzzle >=5.3|~6.0.1|~6.1 -> no matching package found.
    - aws/aws-sdk-php 3.3.3 requires guzzlehttp/guzzle >=5.3|~6.0.1|~6.1 -> no matching package found.
    - aws/aws-sdk-php 3.3.2 requires guzzlehttp/guzzle >=5.3|~6.0.1|~6.1 -> no matching package found.
    - aws/aws-sdk-php 3.3.1 requires guzzlehttp/guzzle >=5.3|~6.0.1|~6.1 -> no matching package found.
    - aws/aws-sdk-php 3.3.0 requires guzzlehttp/guzzle >=5.3|~6.0.1|~6.1 -> no matching package found.
    - aws/aws-sdk-php 3.2.6 requires guzzlehttp/guzzle >=5.3|~6.0.1|~6.1 -> no matching package found.
    - aws/aws-sdk-php 3.2.5 requires guzzlehttp/guzzle >=5.3|~6.0.1|~6.1 -> no matching package found.
    - aws/aws-sdk-php 3.2.4 requires guzzlehttp/guzzle >=5.3|~6.0.1|~6.1 -> no matching package found.
    - aws/aws-sdk-php 3.2.3 requires guzzlehttp/guzzle >=5.3|~6.0.1|~6.1 -> no matching package found.
    - aws/aws-sdk-php 3.2.2 requires guzzlehttp/guzzle >=5.3|~6.0.1|~6.1 -> no matching package found.
    - aws/aws-sdk-php 3.2.1 requires guzzlehttp/guzzle >=5.3|~6.0.1|~6.1 -> no matching package found.
    - aws/aws-sdk-php 3.2.0 requires guzzlehttp/guzzle >=5.3|~6.0.1|~6.1 -> no matching package found.
    - aws/aws-sdk-php 3.1.0 requires guzzlehttp/guzzle >=5.3|~6.0.1|~6.1 -> no matching package found.
    - aws/aws-sdk-php 3.0.7 requires guzzlehttp/guzzle >=5.3|~6.0.1|~6.1 -> no matching package found.
    - aws/aws-sdk-php 3.0.6 requires guzzlehttp/guzzle >=5.3|~6.0.1|~6.1 -> no matching package found.
    - aws/aws-sdk-php 3.0.5 requires guzzlehttp/guzzle >=5.3|~6.0.1|~6.1 -> no matching package found.
    - aws/aws-sdk-php 3.0.4 requires guzzlehttp/guzzle >=5.3|~6.0.1|~6.1 -> no matching package found.
    - aws/aws-sdk-php 3.0.3 requires guzzlehttp/guzzle >=5.3|~6.0.1|~6.1 -> no matching package found.
    - aws/aws-sdk-php 3.0.2 requires guzzlehttp/guzzle >=5.3|~6.0.1|~6.1 -> no matching package found.
    - aws/aws-sdk-php 3.0.1 requires guzzlehttp/guzzle >=5.3|~6.0.1|~6.1 -> no matching package found.
    - aws/aws-sdk-php 3.0.0 requires guzzlehttp/guzzle ^5.3 || ^6.0.1 -> no matching package found.
    - Installation request for league/flysystem-aws-s3-v3 ~1.0 -> satisfiable by league/flysystem-aws-s3-v3[1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4].

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://groups.google.com/d/topic/composer-dev/_g3ASeIFlrc/discussion> for more details.

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

Installation failed, reverting ./composer.json to its original content.

Can someone help me with this error?

Thanks in advance!

Please sign in or create an account to participate in this conversation.

Reply to

Use Markdown with GitHub-flavored code blocks.